cursor, wallpaper and other functions disabled

Thomas Blasejewicz thomas at s7.dion.ne.jp
Mon Jan 5 08:05:57 UTC 2015


On 2014/12/29 17:43, Colin Law wrote:
> On 29 December 2014 at 01:55, Thomas Blasejewicz 
> <thomas at s7.dion.ne.jp> wrote:
>> On 2014/12/28 18:30, Colin Law wrote:
>>> On 28 December 2014 at 00:47, Thomas Blasejewicz <thomas at s7.dion.ne.jp>
>>> wrote:
>>>> On 2014/12/27 17:47, Colin Law wrote:
>>>>> On 27 December 2014 at 04:37, Thomas Blasejewicz 
>>>>> <thomas at s7.dion.ne.jp>
>>>>> wrote:
>>>>>> ...
>>>>>> Anway
>>>>>> AFTER I created the new user and logged off -> logged in again ...
>>>>>> SOMETIMES
>>>>>> I get the usual screen, mouse pointer etc.
>>>>>> But only sometimes.
>>>>>> At other times (I have not had much time to play with this thing; 
>>>>>> the
>>>>>> machine is at home .. I am at work ..) I get something that looks 
>>>>>> like
>>>>>> at
>>>>>> least 500 screens are superimposed on each other ...
>>>>> It might be worth checking by booting off a live image and 'Trying
>>>>> Ubuntu' that it still runs ok, to eliminate hardware issues.
>>>>>
>>>>> Colin
>>>>>
>>>> "Try ubuntu" from live CD causes no problems I can see.
>>>>
>>>> When I log out and then log in again, sometimes things improve,
>>>> but each time (100%) I restart the computer, everything is back to a
>>>> state,
>>>> where a million things do not work.
>>>>
>>>> Anything else I could try?
>>> Have a look in /var/log/syslog and ~/.xsession_errors.
>>>
>>> Colin
>>>
>> The file "syslog" is empty.
> What?  /var/log/syslog is empty?  I find that difficult to understand.
> If correct then there is something very odd going on.  What do you see
> if you open a terminal and type
> ls /var/log
>
>
>> Searching the "file systems" for the ".xsession" file gives "no hits".
> It should be in your users home folder (that's why I said
> ~/.xsession-errors), so /home/your_user_name/.xsession-errors.  Since
> this starts with a . it is a hidden file, so you may not immediately
> see it, but if you open a terminal and type
> ls .xs*
> you should see it.
>
>> Although I tried several times, I have not yet succeeded at "logging 
>> in as a
>> different user", since this too apparently requires
>> some very heavy computer acrobatics that I obviously have not 
>> mastered yet.
> On the login screen do you not see Guest as an option?  Which version
> of Ubuntu are you running (14.04 or whatever)?
>
> If there is no Guest then I don't use xubuntu but I would not have
> expected it to be difficult to add a new user.  Googling for
> xubuntu add user
> gave http://docs.xubuntu.org/1304/administrative-tasks.html as the
> first hit, where it suggests that adding a user is almost trivial (see
> section Managing Users).
>
> But looking back at you message from a couple of days ago you said you
> had already achieved that, so I don't understand what you are saying.
>
>> Looks like just another case of having to start from scratch again .....
> I think I have only ever once had to re-install ubuntu, and that was
> when I suffered a power fail in the middle of updating a kernel.
That is probably, because you know a lot more about computers than I do.
I  have experienced so many troubles that are WAY beyond my 
understanding of computers, that I stopped counting a long time ago.
>
> Colin
>
Well .. finally I was able to create and switch to another user. "Most" 
of the functions are as expected.
Although there are some strange and serious things going on.
With the command you gave me, I finally couldl read the "syslog" file. 
In the file manager it was listed as "0 bytes"
syslog file:
alternatives.log       dpkg.log.2.gz pm-powersave.log.3.gz
alternatives.log.1     dpkg.log.3.gz pm-powersave.log.4.gz
alternatives.log.2.gz  dpkg.log.4.gz          pm-suspend.log
alternatives.log.3.gz  faillog                pm-suspend.log.1
alternatives.log.4.gz  fontconfig.log         pm-suspend.log.2.gz
apt                    fsck                   pm-suspend.log.3.gz
auth.log               gpu-manager.log        samba
boot                   hp                     speech-dispatcher
boot.log               installer              syslog
boot-sav               kern.log               udev
bootstrap.log          lastlog                unattended-upgrades
ConsoleKit             libvirt                upstart
cups                   lightdm                user.log
daemon.log             lpr.log                vbox-install.log
debug                  mail.err               vmware-installer
dist-upgrade           mail.info              vnetlib
dmesg                  mail.log               wtmp
dmesg.0                mail.warn              wtmp.1
dmesg.1.gz             messages               Xorg.0.log
dmesg.2.gz             news                   Xorg.0.log.old
dmesg.3.gz             nova                   Xorg.1.log
dmesg.4.gz             pm-powersave.log       Xorg.1.log.old
dpkg.log               pm-powersave.log.1
dpkg.log.1             pm-powersave.log.2.gz


About the "xsessions" file .. I suspect, that setting up a new user has 
changed it. Because when I finally found it during a manual seach,
there were TWO: one ".xsessions" and one ".xsessions-old". The latter of 
which I cannot open.
When I try to, I am asked with what software I would like to do that and 
I could not find any that will open it.
Anyway, here is the content of the new file:
openConnection: connect: No such file or directory
cannot connect to brltty at :0
Script for ibus started at run_im.


This "old user profile" works better, when I login first to the other 
account and after that into this one, but is still "full of glitches", 
not suitable for any form of "use".

So, would it maybe not better to "move" to the new profile and delete 
the old?
Can I do that?
What will happen to all my folders files?
I tried from the new profile to copy one folder and was told, I am not 
the "owner" of this folder and therefore cannot do anything with it.
The new profile has problems too, but I guess those would require a new 
question.

Thomas



More information about the ubuntu-users mailing list