synaptics package maneger

Gene Heskett gheskett at wdtv.com
Fri Jan 2 21:57:43 UTC 2015


On Friday 02 January 2015 07:33:17 Tom H did opine
And Gene did reply:
> On Thu, Jan 1, 2015 at 1:07 PM, Gene Heskett <gheskett at wdtv.com> wrote:
> > On 10.04.4 LTS, synaptics is the cats meow, doing what it should be
> > able to do.
> > 
> > But on the new mint-17.1 LTS Cinnamon, its best described as broken
> > as two of its most useful features seem to have disappeared, which
> > are:
> > 
> > 1, the ability to refresh, is there, but the ability to mark all
> > upgrades is gone.
> 
> You might want to check on a Mint list because the Mint devs might
> have changed this independently of Ubuntu.

Mint has no mailing list that I can find, and the only way you can log 
into the forum is while running mint, so that is a chicken/egg problem.> 
> > The third impediment being NetworkMangler, which cannot/will not
> > accept a working configuration, causing me to revert to the same
> > methods I used on 10.04.4 and which got me into all sorts of hot
> > water on this list years ago, which is to copy the
> > /etc/network/interfaces file from the old install, and make it
> > immutable. Ditto the /etc/resolv.conf link to something else, nuke
> > it, copy in the old one, and make it immutable too. Instant internet
> > on a init.d/networking restart.
> > 
> > The networking I can fix since everything here on my local net is on
> > fixed addresses using hosts files.
> 
> I was probably one of the people who told you that it was bad practice
> to make resolv.conf immutable.
> 
Probably, but if all NM can do to it is fill it with bogus entries it 
apparently excretes somehow, it is absolutely and totally worthless to me.

> Whether you're using resolvconf or not:

That softlink has been destroyed, and a real resolv.conf set into the 
links place,
 
> - for ifupdown, set "supersede domain-name-servers
> ip_address_of_preferred_nameserver;" in "/etc/dhcp/dhclient.conf"

I do not use a dhcp of any flavor, don't even have a server setup in my 
router, its all hosts file based or network dns queries.  So My machine 
addresses are all fixed.  And it has Just Worked(TM) now for 16 years.
 
> - for NM set "dns=ip_address_of_preferred_nameserver;" in the "[ipv4]"
> section of your connection in
> "/etc/NetworkManager/system-connections/" (this can also be done via
> the nm-applet)
> 
> There's no reason to set "/etc/network/interfaces" as immutable
> because NM only reads it. (If you don't have an empty
> "/etc/network/interfaces" or one where just lo is configured, you have
> to change the NM prefs to use the cofigured interfaces.)

I frankly don't care, this way as I've said many times, is far simpler and 
it works.

> > TBD by a reboot whether or not the NFS lines from this fstab, copied
> > into the new fstab will work, I don't seem to be able to mount the
> > nfs shares by hand even if the fstab line is exactly the same as
> > what works now. It complains that the host share is not in FQDN:dir
> > format, but the instant I try to add the :dir portion it totally
> > fails. Without it, its complains gently and then Just Works(TM).
> 
> What's the fstab entry and what are you mounting by hand?

shop.coyote.den		/net/shop	nfs	defaults 	0	0
lathe.coyote.den	/net/lathe	nfs	defaults	0	0

And its automatic, works from the gitgo at boot with this Lucid install. I 
see the messages about the format while its booting.

If there is a better way to do it than above, I am all eyes?

The by hand mount is this drive, when its been put in slot 2 of this 3 
drive cage, and the drive I just installed is then in slot 1 so the boot 
choice is automatic on power up.

But its all moot for Mint now, I spent the last 6 hours installing a 
custom wheezy from linuxcnc.org on that drive, with a hard realtime 
kernel.  And it let me configure the net during the install and it has 
just worked for 3 reboots now.  And its synaptic just works, very well 
indeed.

So now I should subscribe to the debian mailing list and quite bugging you 
kind folks unless I have an old kde problem, which may not amount to a 
heck of a lot since this kmail is 1.13.5, and the one wheezy just 
installed is 1.13.7, which ought to be able to work with my old configs.

Thanks all.

Cheers, Gene Heskett
-- 
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
Genes Web page <http://geneslinuxbox.net:6309/gene>
US V Castleman, SCOTUS, Mar 2014 is grounds for Impeaching SCOTUS



More information about the ubuntu-users mailing list