TeamViewer on Linux

Petter Adsen petter at synth.no
Sun Dec 6 07:56:05 UTC 2015


On Fri, 04 Dec 2015 14:22:40 +1100
Karl Auer <kauer at biplane.com.au> wrote:

> This is probably not an Ubuntu problem specifically, but if anyone out
> there is using the Linux version of TeamViewer, maybe you can help.
> 
> The object of the exercise is to run TeamViewer on a remote system,
> but have the display on the local system. Exactly as one can do, for
> example, with xterm or pretty much any other X program.
> 
> I log into an Ubuntu system from a different system using "ssh -X
> me at server"
> 
> I run xterm on the server, it works. The xterm window appears on my
> local X server.
> 
> I run a wine application called winbox.exe. It's a Mikrotik router
> configuration application, but (cue Frank Drebin) that's not important
> right now. The point is it's an application being run via WINE. That
> works, too, and the winbox window appears on my local X server.
> 
> Then I run the Linux version of TeamViewer, and it doesn't work.
> Instead I get an error message "X11 connection rejected because of
> wrong authentication". Why?

Have you tried with 'ssh -Y' or enabled ForwardX11Trusted for that host
in the ssh client config?

Petter

-- 
"I'm ionized"
"Are you sure?"
"I'm positive."



More information about the ubuntu-users mailing list