Manually edit ACPI thermal trip point temps & types?

John Hupp ubuntu at
Wed Jun 4 23:42:54 UTC 2014

I have a Lenovo 3000 C200 running Lubuntu 14.04.  It has support for 
ACPI thermal management (e.g. there is a tree at /sys/class/thermal).  
And to be clear, there are no thermal management settings in the BIOS.

The current trip point temp is set high and the type is passive-only.  
I'd like a lower temp with active (fan) type.

I have not found a current tool that knows how to manage these things.  
That was the idea behind acpitool, but it is looking for files at the 
deprecated locations at /proc/acpi, so it seems to be in need of an update.

So I wanted to see what would work manually.

 From /sys/class/thermal/thermal_zone0 I tried:
$ echo -n 40 > trip_point_1_temp
bash: trip_point_1_temp: Permission denied
$ echo -n active > trip_point_1_type
bash: trip_point_1_temp: Permission denied

I tried the same commands with sudo, with the same results.

I also repeated the exercise from 
/sys/devices/virtual/thermal/thermal_zone0, which is where links from 
the above location point.  Same results.

Some things in /sys are meant to be read-only, but the thermal_zone 
attributes should be writable (somehow).

Anyone know how?

And if that succeeds, I imagine that the current defaults would be 
re-established at reboot.  So I'm also wondering about the best way to 
make any changes permanent.

More information about the ubuntu-users mailing list