linux-base not installed but listed in /var/run/reboot-required.pkgs

Colin Watson cjwatson at ubuntu.com
Wed Dec 17 13:18:39 UTC 2014


On Fri, Dec 12, 2014 at 11:35:28AM +0000, Adam Funk wrote:
> I did an apt-get dist-upgrade yesterday, including a new kernel.  I
> rebooted.  Today I'm getting the "System restart required" message.  I
> googled how to find out what package triggered it, so:
> 
> $ cat /var/run/reboot-required.pkgs 
> linux-base
> 
> But dpkg shows that the linux-base package is not installed!  What
> gives?

That's an artificial value used to indicate that the reboot-required
request came from a kernel package, probably because kernel package
names change all the time with ABI changes.  You can see this in the
quite short script /usr/share/update-notifier/notify-reboot-required.

-- 
Colin Watson                                       [cjwatson at ubuntu.com]



More information about the ubuntu-users mailing list