Window 8 in efi mode and Ubuntu in legacy bios mode

Jim Byrnes jf_byrnes at
Wed Oct 23 15:59:06 UTC 2013

On 10/23/2013 08:39 AM, Jim Byrnes wrote:
> On 10/23/2013 05:36 AM, Tom H wrote:
>> On Tue, Oct 22, 2013 at 6:21 PM, Jim Byrnes <jf_byrnes at>
>> wrote:
>>> I haven't actually tried to install Ubuntu yet. I have been holding
>>> off and
>>> gathering info, hoping to improve my chances of success. However if I
>>> do not
>>> disable efi and add nomodeset the live dvd ends at a black screen.
>> Is it a problem with brightness? Is the Live disk fully booted but the
>> screen too dark for you to see the login/desktop?
> I don't think so, but I can't say so with certainty.
>> How about booting with "noacpi"? Or with "acpi_backlight=vendor"?
> I haven't tried that yet but will do so if a couple of other things I am
> going to try fail.
> I have now actually installed Ubuntu and rebooted. If I enable efi I can
> boot Win 8 directly, ie no dual boot menu.  If I disable efi and enable
> csm it tries to boot Ubuntu directly but fails leaving me at a black
> screen. Very early in the booting process I see a message at the top of
> the screen. The first line says something about a microcode failure and
> a file name with amd in it. The second line says kvm disabled by bios.
> It is only on the screen so briefly I can't read it all.
> I burned the boot-repair cd last night and will see if that helps today.
> Regards,  Jim

OK. I ran boot-repair and followed all its prompts. Looks like it 
replaced grub with grub-efi. I made sure efi was enabled and rebooted 
and got a grub menu like this:

Advanced option for Ubuntu
Windows UEFI bkpbootmgfw.efi
Windows Boot UEFI loader

If I select the Windows boot loader it boots to windows.

If I select Ubuntu it tries to boot Ubuntu but I get the message about 
not finding the amd microcode file and stops with the black screen

I tried nosetmode, noacpi and acpi_backlight=vendor.

nosetmode just ended up in the black screen.  noacpi and 
acpi_backlight=vendor seemed to get further in the boot process but 
ended in a black screen but this time there was a cursor flashing in the 
top left corner.

Regards,  Jim

More information about the ubuntu-users mailing list