Ubuntu on a Toshiba Satellite

Jim Byrnes jf_byrnes at comcast.net
Mon Oct 14 19:24:44 UTC 2013

On 10/14/2013 01:02 PM, chris wrote:
> On 15/10/13 05:56, Jim Byrnes wrote:
>> On 10/14/2013 11:27 AM, Liam Proven wrote:
>>> On 14 October 2013 17:07, Jim Byrnes <jf_byrnes at comcast.net> wrote:
>>>> Liam, in another thread you mentioned that you had a Toshiba
>>>> Satellite Pro.
>>>> Does it have Secure boot and EFI?  I am curious as I just had to
>>>> return a
>>>> Toshiba Satellite because I could not get Ubuntu to install and run
>>>> on it.
>>> No, I'm afraid not. It's a P300-1AY - a circa 2008 Core 2 Duo machine
>>> with a conventional BIOS.
>>> AIUI, SecureBoot is only found in association with UEFI, on x86-64
>>> PCs, and it's a requirement for MS to confer the precious "Compatible
>>> with Windows 8" status. It should be possible to disable it in the
>>> firmware setup, though, which is sadly not possible with ARM hardware.
>>> Also, and again AIUI, only 64-bit Linux can cope with it. 32-bit
>>> versions will not install (possibly not even boot).
>> OK, thanks for the reply.
>> Regards,  Jim
> Jim, I am running 13.10 on my Toshiba Satellite pro.
> I had to turn of Secure boot, and efi, then installed win7, and 13.10.
> as a dual boot system.
> Running fine with no problems.
> The win 7 drivers are on the Toshiba web site.
> Regards Chris

Chris, thanks.

I had nothing but trouble.  I turned off Secure boot and tried with efi 
disabled and enabled.  I actually had it installed once but I had no 
networking and Libre Office would not run. I accepted an update hoping 
that it would fix my problem but after that it would not boot.  I tried 
to reinstall and ended up I messed up Win 8 so bad I could not fix it. 
Then I wiped the disk and just tried to install 13.10.

First I tried with efi enabled.  The live DVD booted up but the 
installer would not run.  So I tried to install directly (no live DVD) 
and that worked but I had no networking.  I tried turning off efi and 
using csm ( I think it was caled). It would not boot.  No matter how I 
tweaked the boot order I would get black screen where it mention dchp 
and pxe, which I guess is trying to boot off a lan?I finally got to the 
point  where I only had a couple of days left to return the machine so I 
gave up.

I tried to follow the various how tos on the web, including a couple 
recommended but no luck.  All of them assumed that Win 8 was up and 
running, but the first time I tried I did not setup Win8, maybe that 
effected the out come.  Reading of your success I am tempted to 
repurchase it and try again.

Regards,  Jim

More information about the ubuntu-users mailing list