USB sound

Basil Chupin blchupin at
Sat Oct 5 05:29:31 UTC 2013

On 05/10/13 14:09, Ric Moore wrote:
> On 10/04/2013 11:12 PM, Basil Chupin wrote:
>> On 05/10/13 08:14, Ric Moore wrote:
>>> On 10/04/2013 08:48 AM, R Kimber wrote:
>>>> On Thu, 03 Oct 2013 23:49:03 -0400
>>>> Ric Moore wrote:
>>>>>> I've been having problems with UBS sound for some time (it used to
>>>>>> work
>>>>>> about 6 months ago). I find that any USB sound device that I
>>>>>> connect is
>>>>>> not recognised, and is not listed by aplay -l
>>>>> sudo apt-get install pavucontrol
>>>>> Then open it. Under the playback tab you select the device you 
>>>>> want to
>>>>> play back through from a drop down selection of all the audio devices
>>>>> your system sees. I switch between my USB headset and my 6.1 sound
>>>>> systm
>>>>> all the time using that. I use the headset to not bother other's
>>>>> sleeping. Or, I can blow the cat out the window with 6.1. pavucontrol
>>>>> SHOULD be installed during the install process, but it's not. Go
>>>>> figure.
>>>>> Ric
>>>> Thanks, but pavucontrol gives:-
>>>> Error: unable to connect to pulseaudio: OK
>>>> I should explain that in attempting to resolve this issue I have made
>>>> many
>>>> changes, including disabling pulseaudio.  None of the changes 
>>>> worked.  I
>>>> then purged alsa-base, pulseaudio, and pavucontrol, and then
>>>> re-installed
>>>> them.  This has made no difference, and pulseaudio remains disabled,
>>>> although I reversed the changes that I made previously, and anyway
>>>> purging
>>>> should have removed any changed settings.
>>>> All the relevant modules seem to be loaded OK, including 
>>>> snd_usb_audio.
>>> Methinks if you had pavucontrol installed first, before taking a
>>> hammer to everything, you might have had a chance to be listening to
>>> your tunes. Even a complete purge doesn't always remove all config
>>> files. Maybe look to see if you have any ~/.alsa config
>>> files/directories still lying around, or ~/.asound. rm them with great
>>> prejudice. Something is telling it not to work/start.
>>> It might be easier to re-install cleanly, which I have had to do from
>>> some of my own 'hammering round pegs into square holes" sessions. Heh,
>>> I've done that more than once! Or, just for grins, create a new user
>>> and test my theory, unless you blew something up system wide.
>>> You might just go into /etc/init.d/ and type ./pulseaudio start
>>>     to see what error messages you see. But, if you're like me, you
>>> blew it up real good. :) Ric
>> Or you could open a terminal and run the file on the command line. Doing
>> so will show an error message showing what caused it to fail to run.
> Ah, but the OP related that "Error: unable to connect to pulseaudio:"
> so starting/restarting the deamon might yield more info? Heh, it's 
> gonna be a good bit O fun!

"Nothing ventured nothing gained", as the Actress said to the Bishop.

What the OP quoted may have been the gui message which may be different 
to what one sees on a command line. "Suck it and see", as the Actress 
said to the Bishop :-) .

> Creating a new user would be the easiest test you think? If the new 
> user has the same problem, then the fault will be system wide.

True - but unless one runs it from the command line you will (probably) 
get the same error message and be still none the wiser.

> Mostly some hand edit up somewhere in /etc/alsa?
> Huh, no more alsa in my /etc directory but there is a /etc/pulse 
> directory. Maybe the hand edit is there? I have no .asound in my home 
> directory as well. If he added it, rm it. :) Ric

I don't see any references to alsa in my home directory. But to help to 
find where alsa and pulseaudio are lurking I have posted these 
screenshots of the list of files and where they lurk:

Alsa -

Pulseaudio -



Note that for pulse the list overlaps from image to image but in all 
there are 155 files for pulseaudio (and only 27 for alsa - and who is it 
that dislikes blotware, hmmmmmm? :-) ).

(The screenshots, btw, come from YaST, the openSUSE file manager 


Using openSUSE 13.1, KDE 4.11.2 & kernel 3.11.3-1 on a system with-
AMD FX 8-core 3.6/4.2GHz processor
16GB PC14900/1866MHz Quad Channel Corsair "Vengeance" RAM
Gigabyte AMD3+ m/board; Gigabyte nVidia GTX550Ti 1GB DDR5 GPU

More information about the ubuntu-users mailing list