Total Networking Failure after upgrade to 12.04LTS

Hal Burgiss hal at burgiss.net
Sat Jul 27 14:03:19 UTC 2013


After a server upgrade from 10.04LTS to 12.04LTS, which otherwise seemed
very normal, networking is non-functional. Nothing works (ping, dns, ssh,
etc). Cannot ping any address, even on the LAN, and the system is not
pingable from other systems on the LAN.

The system in question is a 3 yr old Dell PowerEdge R510 server with duel
NIC's, both are Broadcom NetXtreme. This system has no history of problems,
and is used as a file server and internal DNS server for an office LAN. The
original configuration bonded the 2 NIC's. The system is typically managed
remotely via ssh (and thus I have no good way of copy/pasting screen
output). There are no gui tools installed -- its a server. There is no
unusual routing or networking configuration (other than the bonding). No
VPN. Just a very typical single default gateway type set up.

After the upgrade to 12.04, there just is no functional networking of any
kind.

What's been tried:

- pinging localhost and the local network ip address on the NIC both work
normally. pinging anything else, including the default gateway by ip
address, fails with "network unreachable".
- take firewall up / down
- remove bonding (pretty sure this was problematic after the upgrade) +
reboot
- tried NIC's one at a time individually -- identical behavior
- manually reconfigured NIC's with ifconfig and route commands to make sure
there wasn't a config file change that was problematic.
- manually compared the output of ifconfig and route to another similar
working
system (10.04LTS) in the same rack (no difference other than the ip address)
- tried setting NIC's to dhcp (times out)
- turning off apparmor (desperation)
- disabled ipv6 with sysctl (more deperation)

Other factoids:

- Boot sequence looks normal, NIC's are recognized and are shown as
"ready". No errors reported.
- No errors in kern.log or syslog, ever.
- No errors shown by ifconfig.
- Very strangely ifconfig will show both TX and RX steadily incrementing. I
can ping and watch both values change, but pings timeout.
- When the firewall is up, it shows normally looking volume of packets in
both the INPUT and OUTPUT chains. iptables apparently sees incoming
traffic. Symptoms are the same with firewall up or down.
- tcpdump will show arp traffic only, and nothing else. But interestingly
it shows a lot of packets "dropped by kernel".

'tcpdump -vv -X' output summary will look something like:

15 packets captured
369 packets received by filter
350 packets dropped by kernel

I haven't found anything except arp traffic by tcpdump. So does anyone know
what causes "packets dropped by kernel" other than maybe iptables? Or is
this an artifact of something else being wrong, like dns not working? Or
other ideas of what to try?



-- 
Hal
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20130727/1d98e4ec/attachment.html>


More information about the ubuntu-users mailing list