12.04.2 LTS, new install, network broken

Gene Heskett gheskett at wdtv.com
Mon Jul 8 03:41:29 UTC 2013

On Sunday 07 July 2013 23:26:14 Tom H did opine:

> On Sat, Jul 6, 2013 at 1:45 PM, Liam Proven <lproven at gmail.com> wrote:
> > On 6 July 2013 16:04, Gene Heskett <gheskett at wdtv.com> wrote:
> >> I am in a catch-22 here. And very frustrate by what seems to be two
> >> of the dumbest actions ever.  They are:
> >> 
> >> 1. No networking when installing from the cd.  Yes, I have my local
> >> network on 192.168.xx.nn, but apparently the installer cannot cope
> >> if the xx isn't 00.  Inexcusable.
> > 
> > It copes fine on my LAN, which is 192.168.1.xx. So it's not a nonzero
> > 3rd octet; that works fine.
> +1
> > Do you have DHCP?
> Is dhcp working?
I haven't tested recently as the lappy normally lives in my machine shop, 
plugged into a cat5 from another router/switch in the shacks ceiling.

> (And what does "no networking" mean?)

No valid resolv.conf = no dns.  The hosts files worked fine and I could see 
the other two machines out in the shop, which are on a switch, on the local 
side of the router.
> >> 2. The gui tools to properly configure it are disabled because they
> >> refuse to ask for a sudo password in order to modify the files.  So
> >> I am locked ouyt of fixing it via the tools provided.  Also
> >> inexcusable.
> > 
> > GNOME Network Manager (the thing in the panel) is a userspace program.
> > It doesn't need root privileges.
> Only if you want to make the connection available to all users.
> >> I have copied all the networking configs over from a 10.04.4 LTS
> >> install, but I still have no dns, only hostnames in the /etc/hosts
> >> file work.
> > 
> > I would not expect that to work.

Huh?  Hosts files have worked for decades, all you need is a resolv.conf 

order hosts,bind
nameserver address
nameserver address

repeat till you run out of nameservers.

> > Did you keep backups of any files you
> > replaced? Can you revert this change?
> What were the configs that were copied over?!
> Please post the output of:
> nm-tool
> ip a
> ip r
> cat /etc/hosts
> cat /etc/network/interfaces
> cat /etc/nsswitch.conf
> cat /etc/resolv.conf
> ls -l /etc/resolv.conf
> lsattr /etc/resolv.conf

> >> Without a network I cannot update the machine, and without sudo -i
> >> access to the gui the network tab on the top right bar can open, I
> >> cannot save any changes I make to the network configuration.
> > 
> > What does `sudo -i` do? I've never needed it.
> sudo -i = sudo su -
> >> And this bitch goes all the way back to the installer
> >> not properly broadcasting to find out whats out there, so it can use
> >> it during the install.

I take that back, as I was booting from the cd for the 2nd time to verify 
my findings, I noted that it did spend quite a bit of time attempting to 
obtain a dhcp address from the router according to the ports leds.
But IIRC my router isn't setup to allow dhcp services to be offered to this 
machines MAC.  So it never got an address.  Failing that, it should have 
asked me, but did not.
> > Does for me. I use it all the time. Are you saying that even the
> > LiveDVD could not access the network? This is a key question.
> The installer's networking works perfectly well.

Yes it does, IF you configure the network before clicking on the fully 
booted install icon.  If you click on install from the first postcard sized 
screen, it doesn't work.

Thanks Tom.

Cheers, Gene
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
My web page: <http://coyoteden.dyndns-free.com:85/gene> is up!
My views 
Common sense is the most evenly distributed quantity in the world.
Everyone thinks he has enough.
		-- Descartes, 1637
A pen in the hand of this president is far more
dangerous than 200 million guns in the hands of
         law-abiding citizens.

More information about the ubuntu-users mailing list