probe router wirelessly, double NAT

thufir hawat.thufir at
Sun Dec 29 09:51:18 UTC 2013

On Sun, 29 Dec 2013 08:45:31 +0100, Nils Kassube wrote:

> thufir wrote:
>> I'm having some trouble with vuze, so am looking at some networking.
>> The computer uses a wifi adapter to connect with the router.  The
>> adapter is a bit unusual:
>> So the computer gets an IP address from the adapter, and the adapter
>> gets an IP address from the router.  Presumably this is double-NAT?
> I had a look at the manual of your GWU627 and I think the device works
> as a bridge and you have single NAT from your router.
>> thufir at dur:~$ ifconfig eth0      Link encap:Ethernet  HWaddr
>> 00:13:20:ac:13:b0
>>           inet addr:  Bcast:
> [...]
>> thufir at dur:~$ traceroute
> is a private IP address which is only used in your local
> network. Do you have a machine with that IP in your LAN? Or is it a typo
> and you meant which seems to be your router?
>> traceroute to (, 30 hops max, 60 byte packets
>>  1 (  1.364 ms  6.244 ms  6.238 ms 2  * * *
>>  3 (  19.651 ms  21.628 ms  21.655 ms 4 
>> (  21.772 ms rc2bb-
>> (  24.005 ms rc2bb-
>> (  23.947 ms
> Your router tries to find the way to via the public
> internet. That can't work because private addresses should not be
> reachable that way.
> Nils

Exactly, the GWU627 is a bridge.  My ip address is in 192.168.0.x, that's 
what the bride provides. in firefox brings up the interface 
for the Cisco DPC3825 DOCSIS 3.0 Gateway (router).

I **believe** that the DPC3825 gives out addresses in the 192.168.1.x 
range, but I see it as because the GWU627 is a bridge.

Is the above a correct understanding?

Basically, I want to probe the router.  

When I ran 12.04 LTS earlier today, Vuze worked fine.  Now that I've 
installed 13.10, Vuze won't connect (0 users).

I don't see how it could be the router or ISP, but, still, want to try to 
gather some data.



More information about the ubuntu-users mailing list