set up wifi hotspot (share internet connection)

Stephen stephen_o at
Tue Apr 30 17:45:53 UTC 2013

On 30/04/2013 11:56 AM, Nils Kassube wrote:
> Liviu Andronic wrote:
>> On Sat, Apr 27, 2013 at 10:04 PM, Nils Kassube <kassube at>
> wrote:
>>> That's very good, the Atheros wifi chips can be used for AP mode.
>>> Then you should install the package "hostapd" and you can let your
>>> machine work as an access point with WPA2 encryption. IIRC you can
>>> setup the AP with the hostapd configuration [1].
>> Hmm, I found a GUI that allows to set up hostapd, called
>> wifi-hostapd-ap, ( ), but
>> when I run it tells me:
>> "DNSMAQS already in use
>> Warning! It seems that DNSMASQ already in use on your system, as the
>> local DNS. For correct operation of the program, you must disable the
>> local DNS. Before proceeding, please close all connections to the
>> Internet. Continue?"
>> When I press cancel, it then tells me:
>> "To use the program must have full access to DNSMASQ."
>> I tried to disable Networking in NM and then run the utility again,
>> but I get the same message. Any ideas on how I could disable the local
>> DNS?
> Now that you mention it, I remember that dnsmasq is running by default
> on recent *Ubuntu systems. I wasn't aware that it is needed with
> hostapd, but it makes sense indeed. On a (virtual) 13.04 machine I can
> see that dnsmasq is started. But unfortunately I have no idea which
> programm starts it, so I can't tell you how to disable it. Hopefully
> there is someone more knowledgeable here who can help you further.
> Nils
I found this answer at

I found two solutions, I don't want to uninstall the libvirt package so

I either disable it in:



Or edit:


The link was:


More information about the ubuntu-users mailing list