NoMachine NX on Ubuntu 12.10

Dave Woyciesjes woyciesjes at sbcglobal.net
Wed Apr 3 16:42:13 UTC 2013


On 04/03/2013 12:11 PM, Dave Woyciesjes wrote:
> On 04/03/2013 10:41 AM, Dave Woyciesjes wrote:
>> On 04/02/2013 11:25 PM, Keith wrote:
>>> On 03/04/13 08:52, Dave Woyciesjes wrote:
>>>> On 04/02/2013 05:30 PM, Keith wrote:
>>>>> On 03/04/13 06:27, Dave Woyciesjes wrote:
>>>>>>     I'm having a dickens of a time getting NoMachine NX Server
>>>>>> working
>>>>>> on my Ubuntu12.10 system. Will be using a Mac OSX 10.6.8 laptop with
>>>>>> the NoMachine NX Client.
>>>>>>     I created ssh keys on the Mac, exported to Ubuntu. Configured the
>>>>>> OpenSSH as per
>>>>>> https://help.ubuntu.com/community/SSH/OpenSSH/Configuring
>>>>>>
>>>>>> And trying to glean help from here:
>>>>>> http://www.nomachine.com/documentation/html/admin-guide.html
>>>>>>
>>>>>> This is the error when I try to connect on the Mac:
>>>>>>
>>>>>> NX> 203 NXSSH running with pid: 23627
>>>>>> NX> 285 Enabling check on switch command
>>>>>> NX> 285 Enabling skip of SSH config files
>>>>>> NX> 285 Setting the preferred NX options
>>>>>> NX> 200 Connected to address: (server IP) on port: 22
>>>>>> NX> 202 Authenticating user: nx
>>>>>> NX> 208 Using auth method: publickey
>>>>>> NX> 204 Authentication failed.
>>>>>>
>>>>>>
>>>>>> Help!
>>>>>>
>>>>> Can you SSH from your MAC to the Ubuntu *without* using the NX client?
>>>>>
>>>>> It does look like the authentication you have configured for SSH is
>>>>> not
>>>>> setup correctly. I recently tested NX from an Ubuntu to Ubuntu system
>>>>> and it worked very well, and all I did from memory was setup SSH
>>>>> server
>>>>> on Ubuntu box I wanted to connect to copied the SSH key over from the
>>>>> client.
>>>>>
>>>>> Cheers
>>>>> Keith
>>>>>
>>>>>
>>>>     Yeah, setup & tested the SSH first. First I was able to connect
>>>> supplying the password; then I generated & copied the keys over, and
>>>> turned off password auth in the SSH config. Still worked.
>>>>     Looking at the NX output above, it says "Authenticating user: nx".
>>>> but in the NX client setup, I typed in the Ubuntu username. What gives
>>>> there?
>>>>
>>>
>>> I just setup another test from my Ubuntu laptop to a test Ubuntu VM
>>> laptop running 12.10 and vm 12.04.  Was able to connect no problem,
>>> although I did forget and wondered why I started using XRDP instead,
>>> NoMachine doesn't support Unity, so you will need to either setup Gnome
>>> or Kubuntu etc. I think the next version of NX for Linux will support
>>> Unity.
>>
>>      I have Gnome3/Shell installed, so the Unity issue shouldn't be a
>> worry for me. I think.
>>
>>> Your problem though seems to be with  authentication of a nx user, and I
>>> remember something about this in the docs last time, just to be sure I
>>> assume you are entering the username into the NXClient app on your mac
>>> of a user on the Ubuntu machine? Otherwise take a look at this:
>>> http://www.nomachine.com/ar/view.php?ar_id=AR10B00046
>>
>>      Hmmm, this looks very interesting. I'll have to give this a
>> look-see. Thanks much.
>
>      No dice after going through what is mentioned here. Same error as
> above.
>      I didn't see anything, but do I need to create an nx user on the
> Ubuntu side?
>

	Well, I just made some progress. I found this:
http://alien.slackbook.org/dokuwiki/doku.php?id=slackware:nx
	And wen through all. For item #3, my keys were different. Copied the 
key from Ubuntu to the Mac, and now I get the error:
"DSA key is corrupted or has been protected with a passphrase"
Same with NX Client in Win8. I'm guessing my copy & paste wasn't quite 
the right way?

-- 
--- Dave Woyciesjes
--- ICQ# 905818
--- AIM - woyciesjes
--- CompTIA A+ Certified IT Tech - http://certification.comptia.org/
--- HDI Certified Support Center Analyst - http://www.ThinkHDI.com/
             Registered Linux user number 464583

"Computers have lots of memory but no imagination."
"The problem with troubleshooting is that trouble shoots back."
  - from some guy on the internet.




More information about the ubuntu-users mailing list