NoMachine NX on Ubuntu 12.10

Dave Woyciesjes woyciesjes at
Tue Apr 2 21:52:59 UTC 2013

On 04/02/2013 05:30 PM, Keith wrote:
> On 03/04/13 06:27, Dave Woyciesjes wrote:
>>     I'm having a dickens of a time getting NoMachine NX Server working
>> on my Ubuntu12.10 system. Will be using a Mac OSX 10.6.8 laptop with
>> the NoMachine NX Client.
>>     I created ssh keys on the Mac, exported to Ubuntu. Configured the
>> OpenSSH as per
>> And trying to glean help from here:
>> This is the error when I try to connect on the Mac:
>> NX> 203 NXSSH running with pid: 23627
>> NX> 285 Enabling check on switch command
>> NX> 285 Enabling skip of SSH config files
>> NX> 285 Setting the preferred NX options
>> NX> 200 Connected to address: (server IP) on port: 22
>> NX> 202 Authenticating user: nx
>> NX> 208 Using auth method: publickey
>> NX> 204 Authentication failed.
>> Help!
> Can you SSH from your MAC to the Ubuntu *without* using the NX client?
> It does look like the authentication you have configured for SSH is not
> setup correctly. I recently tested NX from an Ubuntu to Ubuntu system
> and it worked very well, and all I did from memory was setup SSH server
> on Ubuntu box I wanted to connect to copied the SSH key over from the
> client.
> Cheers
> Keith
	Yeah, setup & tested the SSH first. First I was able to connect 
supplying the password; then I generated & copied the keys over, and 
turned off password auth in the SSH config. Still worked.
	Looking at the NX output above, it says "Authenticating user: nx". but 
in the NX client setup, I typed in the Ubuntu username. What gives there?

--- Dave Woyciesjes
--- ICQ# 905818
--- AIM - woyciesjes
--- CompTIA A+ Certified IT Tech -
--- HDI Certified Support Center Analyst -
             Registered Linux user number 464583

"Computers have lots of memory but no imagination."
"The problem with troubleshooting is that trouble shoots back."
  - from some guy on the internet.

More information about the ubuntu-users mailing list