Problems with 10.04 upgrade to 12.04

G. Christopher Tuck Jr ctuck22 at
Wed Sep 12 20:42:24 UTC 2012

Following up a thread I found on this topic. Have a partial upgrade to 12.04 completed. When I attempt to upgrade, it failes. I see the following when trying the fixes presented:

root at TuckVPS:/# apt-get install -o APT::Immediate-Configure=false -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
  python: Depends: python-minimal (= 2.6.5-0ubuntu1) but 2.7.3-0ubuntu2 is installed
  python2.7-minimal: Depends: libssl1.0.0 (>= 1.0.0) but it is not installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

My Current Version of Python is: 2.6.5-0ubuntu1

root at TuckVPS:/var/cache/apt/archives# dpkg -l python
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                              Version                           Description
ii  python                            2.6.5-0ubuntu1                    An interactive high-level object-oriented language (default version)

I have tried a number of things with apt-get, aptitude, and dpkg to force the upgrade to Python2.7-minimal and nothing has worked. Found and tried many of the suggestions there. I have tried re-installing 2.6 and 2.5. The next thing I can think to do is manually remove the 2.7.3-0ubuntu2. Aptitude offers some remedies yet never is able to complete them.

Thanks for any insight or help in advance.

More information about the ubuntu-users mailing list