[xubuntu 12.04] Update-manager produces segmentation fault

Liam Proven lproven at gmail.com
Sun Sep 9 12:56:11 UTC 2012

On 8 September 2012 21:51, Robert Spanjaard <spamtrap at arumes.com> wrote:
> On my netbook with Xubuntu 12.04 installed, update-manager suddenly won't
> run anymore. I first noticed it when I tried to run it earlier today from
> the "updates available" notification. It used the CPU for a couple of
> seconds, and then I got the "crash detected" notification.
> When I try to run update-manager from the command line, I get
> "Segmentation fault (core dumped)".
> Some things I already considered:
> 1. Update Manager is the only program that fails. Other package managers
> like Software Center, apt-get and Synaptic run flawlessly.
> 2. Memtest doesn't report any errors. Still, I tried a spare memory
> module just to be safe, but I got the same error.
> 3. Through Google, I found that removing the contents of /var/cache/apt
> solved the problem for some people. But not for me.
> 4. I tried reinstalling update-manager and update-manager-core from
> freshly downloaded packages (ofcourse, after point 3, the cache was
> empty). Still got the same error. :-(
> Any ideas left for me to try?

Try a full update from the command line:

sudo -s

# clean up beforehand

apt-get clean
apt-get autoclean
apt-get autoremove
apt-get purge
apt-get update
apt-get dist-upgrade -y

# clean up again afterwards

apt-get clean
apt-get autoclean
apt-get autoremove
apt-get purge

Then reboot:

shutdown -r now

See if it's any better.

Liam Proven • Profile: http://lproven.livejournal.com/profile
Email: lproven at cix.co.uk • GMail/G+/Twitter/Flickr/Facebook: lproven
MSN: lproven at hotmail.com • Skype/AIM/Yahoo/LinkedIn: liamproven
Tel: +44 20-8685-0498 • Cell: +44 7939-087884

More information about the ubuntu-users mailing list