problems with 10.04 upgrade to 12.04 (procps)

Liviu Andronic landronimirc at
Sat Sep 8 15:07:35 UTC 2012

On Fri, Sep 7, 2012 at 9:58 PM, NoOp <glgxg at> wrote:
> On 09/07/2012 11:43 AM, Liviu Andronic wrote:
>> However, I'm still unable to boot Precise. Using default kernel
>> parameters (for 3.2.0) I get the following messages:
>> [..]
>> Begin: Running /scripts/init-bottom ... done.
>> could not log bootup: Address already in use
>> [ 10.1 ] init: plymouth main process (327) terminated with status 69
>> mount: Too many levels of symbolic links
>> mountall: mount /run [349] terminated with status 32
>> mountall: Filesystem could not be mounted: /run
>> An error occurred while mounting /run.
> Are you able to boot to recovery mode?
No, not really. If I try to boot with default kernel options (the
'recovery' variant), then the booting gets stuck as described earlier
at mounting the various partitions. The only way to get myself on a
console is to use the 'rw init=/bin/bash' kernel parameters which
let's me fall back to a console with 'rw' permission on /. This is not
quite the recovery mode.

> If so, can you try the dpkg option?
I'm not sure that I follow. How do I do that? Is this a kernel
parameter, or some other option?

>> Then I press S to skip mounting and I get the following:
>> The disk drive for / is not ready yet or not present.
>> Skipping /run at user request
>> udevd[359]: error: runtime dir '/run/dev/' not writable, for now
>> falling back to '/dev/.udev'
>> Next I press M for manual recovery and get this:
>> Root filesystem check failed.
>> A maintenance shell will now be started.
> That sounds like the cryptswap issue:
> <>
> if so, then generally it will time out after a moment or two.
Hmm, this didn't work for me. I waited for ~30min and the screen was
still stuck at 'continue to wait' while trying to mount the /

But I'm not sure that I'm seeing the same issue. For one, the first
time such an issue arises is while running 'mount /run'; I don't have
such a device in /etc/fstab. And the second thing is that I tried
booting up without swap, commenting out the /dev/sda7 and
/dev/mapper/cryptoswap related items in /etc/fstab ( ), and still got the same booting

>> All this looks strange to me, as I force checked / (and all other FS)
>> and they're all clean. I'm wondering though if after installing all
>> the packages there were some Precise-specific scripts that didn't get
>> executed to prepare the new OS. Among other things, perhaps /etc/fstab
>> didn't get updated? (Here's my current /etc/fstab:
>> )
> Do the UUID's match against:
> $ sudo blkid
Yes. The only difference that I can spot is that the 'swap' partition
doesn't come up in the blkid output.
 fdisk -l:

> And  does
> $ sudo fdisk -l
> show the cryptswap?
The /dev/sda9 partition is in the output, but it is marked as 'linux',
not 'cryptswap'.

>> Should I run 'do-release-upgrade' again?
> Try the recovery dpkg option first.
I'm not sure how exactly I should use the recovery dpkg option.


More information about the ubuntu-users mailing list