problems with 10.04 upgrade to 12.04 (procps)

Liviu Andronic landronimirc at
Fri Sep 7 18:43:20 UTC 2012

On Fri, Sep 7, 2012 at 7:04 PM, NoOp <glgxg at> wrote:
> On 09/07/2012 02:06 AM, Liviu Andronic wrote:
> ...
>> So now I can boot Precise to a console with rw permissions on /. [4]
>> However installing 'procps' or 'cron' fail with the exact same error
>> message: "Unable to connect to Upstart: Failed to connect to socket
>> /com/ubuntu/upstart: Connection refused". This suggests to me that the
>> whole upstart/initctl/invoke-rc.d machinery hasn't been initialized in
>> the session and the install scripts for several packages fail because
>> of that.
>> If I try the following I get an error message:
>> # start procps
>> start: Unable to connect to Upstart: Failed to connect to socket
>> /com/ubuntu/upstart: Connection refused
>> If I try the following I also get an error message:
>> # upstart-socket-bridge
>> upstart-socket-bridge: Couldn't connect to Upstart: Failed to connect
>> to socket /com/ubuntu/upstart: Connection refused
> I see you got this sorted out:
> <>
Almost.. I indeed managed to complete the upgrade by following the
suggestion in comment 17 in the bug above: There are no more packages
to configure/update/install.

However, I'm still unable to boot Precise. Using default kernel
parameters (for 3.2.0) I get the following messages:
Begin: Running /scripts/init-bottom ... done.
could not log bootup: Address already in use
[ 10.1 ] init: plymouth main process (327) terminated with status 69
mount: Too many levels of symbolic links
mountall: mount /run [349] terminated with status 32
mountall: Filesystem could not be mounted: /run
An error occurred while mounting /run.

Then I press S to skip mounting and I get the following:
The disk drive for / is not ready yet or not present.
Skipping /run at user request
udevd[359]: error: runtime dir '/run/dev/' not writable, for now
falling back to '/dev/.udev'

Next I press M for manual recovery and get this:
Root filesystem check failed.
A maintenance shell will now be started.

All this looks strange to me, as I force checked / (and all other FS)
and they're all clean. I'm wondering though if after installing all
the packages there were some Precise-specific scripts that didn't get
executed to prepare the new OS. Among other things, perhaps /etc/fstab
didn't get updated? (Here's my current /etc/fstab: )

Should I run 'do-release-upgrade' again?


More information about the ubuntu-users mailing list