problems with 10.04 upgrade to 12.04

Dave Howorth dhoworth at
Thu Sep 6 10:33:49 UTC 2012

NoOp wrote:
> So you followed all of the suggestions in the bug report that I pointed
> you to:
> [upgrading from lucid to precise fails]
> including:
> <quote>
> If you didn't use update-manager (or do-release-upgrade from
> update-manager-core) to do your upgrade please do so next time instead
> of trying to upgrade with only apt. You'll get much better results.
> How to get past this:
> # apt-get install -o APT::Immediate-Configure=false -f apt python-minimal
> # apt-get -f install
> # apt-get dist-upgrade
> </quote>
> right?

Hi Noop,

Yes and no. I tried the first of those three steps and it failed. I've
also tried the second of those steps and it failed. So I haven't tried
the third step. I've tried variations of steps 1 (with and without dpkg
and apt) & 2 multiple times; step 1 currently returns:

> # apt-get install -o APT::Immediate-Configure=false -f apt python-minimal
>   update-manager-core: Depends: python2.7 but it is not going to be installed
>                        Depends: python (>= 2.7.1-0ubuntu2) but 2.6.5-0ubuntu1 is to be installed
>   vim-gnome: Depends: vim-gui-common (= 2:7.3.429-2ubuntu2.1) but 2:7.2.330-1ubuntu3 is to be installed
>              Depends: vim-common (= 2:7.3.429-2ubuntu2.1) but 2:7.2.330-1ubuntu3 is to be installed
>              Depends: vim-runtime (= 2:7.3.429-2ubuntu2.1) but 2:7.2.330-1ubuntu3 is to be installed
>              Depends: libperl5.14 (>= 5.14.2) but it is not going to be installed
>              Depends: libpython2.7 (>= 2.7) but it is not going to be installed
>              Depends: libruby1.8 (>= but is to be installed
>              Depends: tcl8.5 (>= 8.5.0) but it is not going to be installed
> E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

The output from step2 is longer. I've attached the log from the latest
run to the bug report:

> BTW: I recommend that you do that from the recovery boot as root with
> networking. Otherwise, just make sure that you either use 'sudo' instead.

I'm not quite sure what your 'Otherwise' sentence means. I'm logged in
via ssh.

> And what other suggestions in that bug report did you try & what
> happened after you tried them?

I haven't tried changing repositories. I have tried running apt-get in
many variations. I've tried running dpkg --configure -a a couple of
times and the logs are attached to the bug report. I tried running
apport but it won't run. I think the safest path now is to work with
current evidence - I'll run any command you like and post the log.

It seems to be some dependency problem. I'm not skilled enough to
identify the root cause of that, or to know what commands I can use to
recover from it.

> Note: I see that you stated that this is a server for your boss & it
> seems be working. *Don't* attempt any of the following without first
> backing up the server. Provide the output of the following:
> $ uname -a

$ uname -a
Linux pcx36 2.6.32-42-generic #95-Ubuntu SMP Wed Jul 25 15:57:54 UTC
2012 i686 GNU/Linux

> Also, before attempting the upgrade you followed the release notes:
> <>
> and
> <>

I tried to follow the instructions in the second of those, which state
that the first is relevant until the point release has happened.

> 1. Describe as best you can remember the steps that you performed to do
> the upgrade.
> 2. Also, given that you are running a server with a graphical desktop
> (lxde), let us know if *prior* to the upgrade you did any of the
> following (note some are not mentioned in the release notes):
> a. sudo apt-get install update-manager-core
> b. sudo apt-get update && sudo apt-get upgrade
> c. sudo apt-get install ubuntu-desktop lubuntu-desktop
> d. sudo apt-get install -f
> e. sudo dpkg --configure -a

I don't remember doing any of those. According to shell history, I did:

  449  ls /usr/share/doc/update-manager-text/
  450  update-manager-text
  451  update-manager-text
  452  cls
  453  clear
  454  su - scop2-apache
  455  top
  456  crontab -e -u www-data
  457  crontab -e -u www-data
  458  top
  459  do-release-upgrade
  460  do-release-upgrade

I ran update-manager-text because I was trying to follow the
instructions mentioned above, but am not using the GUI. The scop2-apache
and crontab commands are irrelevant AFAIK. I was tuning some website

> Note: lxdm is nothing more than the lxde desktop manager; same as the
> gdm or lightdm login managers.
> Here is what I recommend (backup & the standard 'if you break it you pay
> for it' applies):

Yes, it's backed up every night, and the last good backup before the
upgrade is now set to be kept for a year.

> - create a root account:
> <>
> (don't forget to remove it when finished).

I have a root account already (sorry, I tried the ubuntu way but I'm

OK I'll sign off and post this now. I'll try the detailed command
sequence you suggest below after lunch unless anybody intervenes in the

Thanks for your help,

> - reboot & login with recovery mode
> - enable network (can't recall the exact menu(s) as I need to reinstall
> 10.04 to detail but I'm pretty sure it's 'network') - select 'yes'
> regarding  a remount etc at the prompt.
> - select 'root' & give your newly added root password
> - Run through these commands in the exact order provided:
> a. apt-get install update-manager-core
> b. apt-get install -o APT::Immediate-Configure=false -f apt python-minimal
> c. apt-get update && apt-get upgrade
> d. apt-get install -- reinstall ubuntu-desktop lubuntu-desktop
> Note: the 'lubuntu-desktop' is because you installed ldxe - you can
> leave it off if you wish, but ensure that you 'install --reinstall
> ubuntu-desktop'.)
> e. apt-get -f install
> f. dpkg --configure -a
> Note: you many have to repeat these a few times to get things to work &
> settle down. If they still continue to fail, go to 'f' & then 'e'.
> f. apt-get update && apt-get upgrade
> Note: up arrow a few times will get you back to this command
> f. exit
> This will return you to the recovery menu & the natural instinct is to
> click 'resume'. That works, but returns you to a low graphics status at
> the desktop gm; click it if you wish, but then reboot to get back to
> actual desktop graphic settings.
> Reboot & once back on the desktop (lxde?) if the above completed without
> further errors, go back to the upgrade links & bring up the update
> manager & try the upgrade again. If that still fails to work, use
> to paste whatever ouput you can.

More information about the ubuntu-users mailing list