Gedit – C-code – Print to HP Color LaserJet CM1312-MFP – some characters missing

Johnny Rosenberg gurus.knugum at
Tue Sep 4 19:41:38 UTC 2012

I have a too old version of Ubuntu (10.10) and I WILL upgrade soon,
maybe this weekend, but here's my question anyway:

I write some C with Gedit and I use the standard colour scheme. When
printing, some characters are not printed out correctly, for example
”sizeof” is printed as ”si▯eof”. I have tried different fonts, for
example Monospace 8 and Liberation Mono 8, same result. I tried
printing as PDF. The PDF looked fine, but when I printed it, the same
problem occured again.

I tried other colour schemes as well. With the ”Kate” scheme, ”sizeof”
looked right but ”for” was printed as ”fo▯”. I use the HP-lip thing
for the printer. It seems like certain colours in different font types
(bold, italic etc) gives different results. I also tried other editors
than Gedit, but still the same result as long as the colours and font
type were the same.

So it looks like this is a HP-lip issue or a printer issue, right?

So, my question is:
Does anyone here have the same printer? If so, do you have the same
issue? Can I expect this issue to disappear after upgrading (or rather
install from scratch in my case) to 12.04?

Kind regards

Johnny Rosenberg

More information about the ubuntu-users mailing list