Acer notebook WiFi

wcj9996 wcj9996 at
Mon Mar 26 23:36:38 UTC 2012


Several days ago I bought an Acer Aspire One 722-0825 Laptop.  It all 
works very well with Windows 7 Home Premium, including the WiFi.  I 
installed Ubuntu 11.10  X64 with the wired connection to my router 
connected to simplify installation and update installation.  When I 
activated the WiFi the computer froze.  No cursor movement and no 
control-alt-backspace  reaction.  I powered down, disconnected the wired 
network connection and re-booted.  As soon as the desktop came up it 
froze again.  I have tried Mint 12 X64 live boot with the same result.

It appears to me that it loads the driver and logs into the router as 
expected but as soon as it attempts to access the Local Area Net it 
crashes hard.

The network chips identified by lspci:

walt at tiger:~$ lspci | grep Ath
06:00.0 Ethernet controller: Atheros Communications AR8152 v2.0 Fast 
Ethernet (rev c1)
07:00.0 Network controller: Atheros Communications Inc. AR9485 Wireless 
Network Adapter (rev 01)

The drivers:

walt at tiger:~$ lsmod | grep ath
ath9k                 127538  0
mac80211              462046  1 ath9k
ath9k_common           13839  1 ath9k
ath9k_hw              312914  2 ath9k,ath9k_common
ath                    24067  2 ath9k,ath9k_hw
cfg80211              199630  3 ath9k,mac80211,ath

The last few lines of dmesg:

26.409283] init: plymouth-stop pre-start process (1330) terminated with 
status 1
[   26.598890] wlan0: authenticate with 00:23:69:c5:8a:8d (try 1)
[   26.603190] wlan0: authenticated
[   26.623088] wlan0: associate with 00:23:69:c5:8a:8d (try 1)
[   26.631556] wlan0: RX AssocResp from 00:23:69:c5:8a:8d (capab=0x411 
status=0 aid=1)
[   26.631568] wlan0: associated
[   26.638439] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   29.174033] EXT4-fs (sda6): re-mounted. Opts: 
[   32.192211] eth0: no IPv6 routers present
[   37.248274] wlan0: no IPv6 routers present

Iwconfig results:

tiger:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"walnut"
           Mode:Managed  Frequency:2.462 GHz  Access Point: 
           Bit Rate=72.2 Mb/s   Tx-Power=16 dBm
           Retry  long limit:7   RTS thr:off   Fragment thr:off
           Power Management:on
           Link Quality=67/70  Signal level=-43 dBm
           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
           Tx excessive retries:0  Invalid misc:56   Missed beacon:0

I haven't been able to find any help on Google.  WiFi while traveling is 
the reason I bout this machine.

Thanks for your help.


-----  walt  wcj9996 at -----

More information about the ubuntu-users mailing list