Login failure after restart. Every time.

Basil Chupin blchupin at iinet.net.au
Mon Mar 26 11:51:00 UTC 2012

On 24/03/12 03:00, Kevin O'Gorman wrote:
> On Fri, Mar 23, 2012 at 6:00 AM, Basil Chupin<blchupin at iinet.net.au>  wrote:
>> On 23/03/12 19:13, Kevin O'Gorman wrote:
>>> On Thu, Mar 22, 2012 at 9:18 PM, Basil Chupin<blchupin at iinet.net.au>
>>>   wrote:
>>>> I just checked 'man fsck' and there is no "-f" parameter/[switch] for
>>>> fsck.
>>>> There is "-r" but no "-f".
>>>> BC
>>> You have to read quite carefully to get it and be familiar with the
>>> filesystem-specific options for your filesystem.  Since the -f option
>>> is not recognized by fsck proper, it is passed on the the actual
>>> filesystem-specific executable.  For most filesystems, it's a
>>> force-flag that makes fsck.??? do a full check.
>> I see.
>> What you are trying to say is that it is an undocumented "feature".
> I am not.  Not at all.
>  From output of "man fsck":
>         fs-specific-options
>                Options  which  are  not  understood  by  fsck are
> passed to the filesystem-specific checker.
>                These arguments must not take arguments, as there is no
> way for fsck to be able  to  properly
>                guess which arguments take options and which don't.
>                Options  and  arguments which follow the -- are treated
> as file system-specific options to be
>                passed to the file system-specific checker.

Sorry for the delayed response but I have been trying to solve a couple 
of (nasty) hassles - one solved the other still in play :'( .

OK, what all of the above states is that if fsck does not understand 
what it is you are trying to do then it sends the command to the 
"filesystem-specific checker" - which in case, assuming that you are 
using one of the extX filesystems, to e2fsck and with the parameter 
"-f"; and the "-f" parameter in e2fsck means to "force a check". If I 
remember correctly, the "f" parameter in Windows/OS2 chkdsk means "fix 

Now, what I stated right from the start is that fsck is performed 
automatically on each boot of system and it found NOTHING wrong with the 
files system (ext4) on my wife's computer. Nothing - no errors, zilch, 
and yet her system was playing up something aweful. So, as I stated, I 
ran e2fsck manually and this found a host of errors; and because I did 
not use the "-p" parameter in e2fsck I was able to see what those errors 
were and answered YES everytime e2fsck asked if I wanted them to be 

If you are happy with the result of your exercise in running 'fsck -f' 
then I shall debate the issue with you no further. I can only relate to 
you my personal, real life, experience and how I solved my wife's 
computer hassles :-) .


The more sand has escaped from the hourglass of our life, the clearer we should see through it.
              Niccolo Machiavelli

More information about the ubuntu-users mailing list