Ubuntu one crashes

Sam Sebastian sebastiansam55 at gmail.com
Sat Mar 10 23:34:03 UTC 2012


I need some help, I'm currently using Linux Mint (lxde) with ubuntuone
installed, and the system is fully up to date, when i try to open the
"Ubuntu One" listing in the system menu nothing happens,
I tried to run it from the command line;
it says i have these commands installed (tab completion)
ubuntuone-control-panel-gtk  ubuntuone-launch
ubuntuone-installer

launching any of these will end with some kind of python error;

for ubuntuone-control-panel-gtk:
"""
Traceback (most recent call last):
  File "/usr/bin/ubuntuone-control-panel-gtk", line 33, in <module>
    from ubuntuone.controlpanel.gui.gtk import main
  File
"/usr/lib/python2.7/dist-packages/ubuntuone-control-panel/ubuntuone/controlpanel/gui/gtk/__init__.py",
line 28, in <module>
    from ubuntuone.controlpanel.gui.gtk.gui import main
  File
"/usr/lib/python2.7/dist-packages/ubuntuone-control-panel/ubuntuone/controlpanel/gui/gtk/gui.py",
line 35, in <module>
    from ubuntuone.platform.credentials import (
  File
"/usr/lib/python2.7/dist-packages/ubuntuone-client/ubuntuone/platform/__init__.py",
line 10, in <module>
    from ubuntuone.platform import linux
  File
"/usr/lib/python2.7/dist-packages/ubuntuone-client/ubuntuone/platform/linux/__init__.py",
line 60, in <module>
    from ubuntuone.platform.linux.filesystem_notifications import
FilesystemMonitor
  File
"/usr/lib/python2.7/dist-packages/ubuntuone-client/ubuntuone/platform/linux/filesystem_notifications.py",
line 26, in <module>
    from twisted.internet import abstract, reactor, error, defer
  File
"/usr/local/lib/python2.7/dist-packages/twisted/internet/abstract.py", line
17, in <module>
    from twisted.python import log, reflect, components, failure
  File
"/usr/local/lib/python2.7/dist-packages/twisted/python/components.py", line
68, in <module>
    from zope.interface.adapter import AdapterRegistry
  File "/usr/local/lib/python2.7/dist-packages/zope/interface/adapter.py",
line 195
    for with, objects in v.iteritems():
           ^
SyntaxError: invalid syntax
"""

for ubuntuone-installer
"""

(ubuntuone-installer:29130): Gtk-WARNING **: Theme parsing error:
gtk-buttons.css:159:10: Expected valid border
sam at mint ~ $ Traceback (most recent call last):
  File "/usr/bin/ubuntuone-control-panel-gtk", line 33, in <module>
    from ubuntuone.controlpanel.gui.gtk import main
  File
"/usr/lib/python2.7/dist-packages/ubuntuone-control-panel/ubuntuone/controlpanel/gui/gtk/__init__.py",
line 28, in <module>
    from ubuntuone.controlpanel.gui.gtk.gui import main
  File
"/usr/lib/python2.7/dist-packages/ubuntuone-control-panel/ubuntuone/controlpanel/gui/gtk/gui.py",
line 35, in <module>
    from ubuntuone.platform.credentials import (
  File
"/usr/lib/python2.7/dist-packages/ubuntuone-client/ubuntuone/platform/__init__.py",
line 10, in <module>
    from ubuntuone.platform import linux
  File
"/usr/lib/python2.7/dist-packages/ubuntuone-client/ubuntuone/platform/linux/__init__.py",
line 60, in <module>
    from ubuntuone.platform.linux.filesystem_notifications import
FilesystemMonitor
  File
"/usr/lib/python2.7/dist-packages/ubuntuone-client/ubuntuone/platform/linux/filesystem_notifications.py",
line 26, in <module>
    from twisted.internet import abstract, reactor, error, defer
  File
"/usr/local/lib/python2.7/dist-packages/twisted/internet/abstract.py", line
17, in <module>
    from twisted.python import log, reflect, components, failure
  File
"/usr/local/lib/python2.7/dist-packages/twisted/python/components.py", line
68, in <module>
    from zope.interface.adapter import AdapterRegistry
  File "/usr/local/lib/python2.7/dist-packages/zope/interface/adapter.py",
line 195
    for with, objects in v.iteritems():
           ^
SyntaxError: invalid syntax
"""

for ubuntuone-launch
"""
Traceback (most recent call last):
  File "/usr/bin/ubuntuone-launch", line 56, in <module>
    from ubuntuone.platform.credentials import CredentialsManagementTool
  File
"/usr/lib/python2.7/dist-packages/ubuntuone-client/ubuntuone/platform/__init__.py",
line 10, in <module>
    from ubuntuone.platform import linux
  File
"/usr/lib/python2.7/dist-packages/ubuntuone-client/ubuntuone/platform/linux/__init__.py",
line 60, in <module>
    from ubuntuone.platform.linux.filesystem_notifications import
FilesystemMonitor
  File
"/usr/lib/python2.7/dist-packages/ubuntuone-client/ubuntuone/platform/linux/filesystem_notifications.py",
line 26, in <module>
    from twisted.internet import abstract, reactor, error, defer
  File
"/usr/local/lib/python2.7/dist-packages/twisted/internet/abstract.py", line
17, in <module>
    from twisted.python import log, reflect, components, failure
  File
"/usr/local/lib/python2.7/dist-packages/twisted/python/components.py", line
68, in <module>
    from zope.interface.adapter import AdapterRegistry
  File "/usr/local/lib/python2.7/dist-packages/zope/interface/adapter.py",
line 195
    for with, objects in v.iteritems():
           ^
SyntaxError: invalid syntax
"""


planning to do clean upgrade to 12.04 so this will hopefully become moot
point sooner or later but it'd be nice if i could get it fixed before then.
Misc info
installed ubuntuone app for android and have it synced
all my logins are the same and have not changed since i set it up on my
computer

thanks, Sam
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20120310/488397b3/attachment.html>


More information about the ubuntu-users mailing list