your version of GraphicsMagick limits images to 8 bits per pixel

龙永彪 longyongbiao at gmail.com
Fri Mar 9 16:27:55 UTC 2012


Hello, I'm using GNU Octave,  When I ran:
     I = imread ("mypic.png");
I got:
warning: your version of GraphicsMagick limits images to 8 bits per pixel

After I google it, I got the reason in
http://octave.1599824.n4.nabble.com/GraphicsMagick-limitations-td3523937.html

"
GraphicksMagick can be built with:
--with-quantum-depth=8
--with-quantum-depth=16
--with-quantum-depth=32
"

I also track a related bug in debian:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=557879

But I still don't know how to deal with it.  Do I need to build
GraphicsMagick with
--with-quantum-depth=16 myself? Or if I could compile it from source?

Any suggestions?

-- 
Best Regards
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20120310/5c9fb438/attachment.html>


More information about the ubuntu-users mailing list