eject not working unless I'm root

Ric Moore wayward4now at gmail.com
Tue Mar 6 20:06:54 UTC 2012

On 03/06/2012 01:58 PM, Liam Proven wrote:
> On 6 March 2012 08:40, Ric Moore<wayward4now at gmail.com>  wrote:
>> Anyone knows what gives with that??
>> My DVD isn't playing and yes, been through the how-to a dozen times. Using
>> Xubuntu 11.10. A data disk is recognized. A few days ago I played a music CD
>> but now that doesn't work either. My user is a member of the cdrom group.
>> There must be a flakey udev rule tossing things into the grinder as I had to
>> sudo eject for it to happen.  Ric
> Is that not normal? I'm not sure, I seldom use `eject` except when
> doing things like copying disks, when I normally do run as root.
> Have you tried unmounting the disk first?

As I mentioned, after last night's updates, it works now. The eject 
command is linked to /dev/cdrom. Your user should be in the group 
"cdrom" in order to eject stuff. So, when I had to sudo the command, 
something was dead wrong. It works now, without the sudo. "Yeah," says 
Detective Ric, "I was hot on their trail of stale smokes and warm beers.'

Now I can play a cd. No go on DVD's as of yet. Would someone post their 
working desktop preferences command to play a DVD? I have:
   vlc dvd://%d  in mine.

I think I've been here before ...deja vu.
<weeeeuuuh!> Ric

My father, Victor Moore (Vic) used to say:
"There are two Great Sins in the world...
..the Sin of Ignorance, and the Sin of Stupidity.
Only the former may be overcome." R.I.P. Dad.

More information about the ubuntu-users mailing list