Editing /etc/passwd to disable password not working

Ken Adams adams.ken.j at gmail.com
Thu Mar 1 10:43:15 UTC 2012

On Thu, 2012-03-01 at 14:56 +0530, Santanu Chatterjee wrote:
> Hello Everybody,
> I tried to disable the password of an account on my home ubuntu 11.04
> box, by blanking the 2nd field of the corresponding user line in
> /etc/passwd and /etc/shadow file. However, whenever I try to login to
> the user account I am still being asked for the password and just
> pressing 'enter' is not working.
> Is there something else that I should be doing? IIRC, I have tried
> this some time back in probably ubuntu 8.10 (or maybe some lower
> version) and it used to work.
> Thanks and regards,
> Santanu

If you use the following the account will stay in place but be inactive.

sudo passwd --lock [LOGIN]

If you wish to activate the account again then use...

sudo passwd --unlock [LOGIN]

This will put activate the account with the original password.

man passwd is your friend

Rgds Ken

More information about the ubuntu-users mailing list