Mounted partition is suddenly read only

JD jd1008 at
Tue Dec 18 05:38:03 UTC 2012

I have a 1.5TB drive partitioned into 5 partitions.
partition 3(ext3) has in it the dir home.

/home is a symlink to /sdb3/home

The rest of the mounted partitions are
/sdb1, /sdb4 /sdb5.  /sdb2 is a swap partition.

I had left the system idle for many hours.
When I returned to it,I found my home dir
was no longer write-able.
So, I tried:

# mount -o remount,rw /sdb3
and got

mount: cannot remount block device /dev/sdb3 read-write, is write-protected

None of the other sdb partitions are affected in this way.
To wit:

# for i in 1 3 4 5; do
 > [ ! -d /sdb$i/tmp ] && mkdir /sdb$i/tmp
 > touch /sdb$i/tmp/junk$i
 > done
touch: cannot touch `/sdb3/tmp/junk3': Read-only file system

The other partitions are not affected.

I googled this and tried several of the solutions (which do not require 
None of them worked.

Rebooting into rescue mode, running fsck and then going multiuser
works, but only for a while (i.e. until I leave the system idle for a 
and the issue repeats itself.

More information about the ubuntu-users mailing list