Twinview in 12.04

Jim Byrnes jf_byrnes at comcast.net
Tue Dec 11 21:52:23 UTC 2012


On 12/11/2012 10:25 AM, Liam Proven wrote:
> On 11 December 2012 16:03, Jim Byrnes <jf_byrnes at comcast.net> wrote:
>> On 12/11/2012 09:10 AM, Liam Proven wrote:
>>>
>>> On 11 December 2012 07:53, Ric Moore >
>>>>
>>>> Install the correct video driver (not that nouveau crap) and then use
>>>> nvidia
>>>> X-config settings to set the monitors, resolutions and then write it out
>>>> to
>>>> /ect/X11/xorg.conf from the X Server Display tab. Logout and back in
>>>> again.
>>>> Works a charm with 12.04. Ric
>>>
>>>
>>> I have to agree.
>>>
>>> Also note carefully what monitor connections you are using.
>>>
>>
>> I have done all of the above.
>>
>> I have tried 3 drivers.  The first one I used was the 1st one on the list
>> when I clicked on the additional drivers icon. Then I tried the second on
>> the list which was labeled "post release".  Finally I tried the nouveau
>> drivers.
>>
>> The HP is a standard vga connection and the Hannspree is hdmi. I was able to
>> set both at 1920x1080 60hz using 10.04.
>>
>> Right now 12.04 is unusable. When I boot to it I get a message that there is
>> no usable stored configuration and the HP has a black screen and the
>> Hannspree is very low res with no mouse cursor.
>>
>> At this point I want to reinstall 12.04.  I boot from the install cd and it
>> sees that 10.04 and 12.04 are installed. (note they are on separate HD's). I
>> choose the option to format and install. It says everything will be replaced
>> and then asks if I want to continue. Maybe I am being overly cautious, but
>> at this point I canceled because I want to be sure if I click continue I
>> will be offered the clear option to install on the 12.04 disk. Is this the
>> case?
>
> Did the drivers actually install correctly? Was there a green dot next
> to them after you rebooted? If so, were you then able to run the
> ``nvidia-settings'' command?
>

Yes the green dot appears.  I used the gui not the command line and it 
gave me access to settings for both monitors.  The problem is that the 
highest resolution I could set for the Hannspree was 1360x768.  On my 
10.04 install it let me set it at 1980x1080 just like the HP. In an 
earlier message I made a mistake.  The HP is connected via hdmi and the 
Hannspree is vga, I reported it the opposite in a previous message.

I have now tried the install of 12.04 multiple times in multiple ways. 
When I installed 10.04 I had only one monitor, the HP. So I disconnected 
the Hannspree and installed with only the HP active, still no good after 
adding the Hannspree. Tried it with just the Hannspree and then adding 
the HP, no good.

A couple of things I noticed doing all of these re installs.

During the installation I would get a system program error.  When I 
clicked on the report error box the detail would say "Executable path 
/usr/bin/jockey-gtk.  Results from googling said to re install it, I did 
that but it did not help.

When I was in the Nvidia setting gui and I clicked on the "save 
configuration" button I would get an error popup saying "Failure to 
parse X configure file". After clearing that error I would get a popup 
allowing me to save the file.

I am starting to think that Twinview is just a symptom of some other 
problem. So I think I will do some research on 12.04 and jockey plus the 
Nvidia drivers.  Then download and burn a new CD if necessary and start 
a new thread if that doesn't work.  Thanks for everyone's help.

Regards,  Jim







More information about the ubuntu-users mailing list