Permission problem with some GUI apps

JD jd1008 at
Tue Dec 11 21:09:42 UTC 2012

On 12/11/2012 01:34 PM, Colin Law wrote:
> On 11 December 2012 18:04, JD <jd1008 at> wrote:
>> On 12/11/2012 12:59 AM, Colin Law wrote:
>>> On 11 December 2012 05:17, JD <jd1008 at> wrote:
>>>> Running evince, I get the following error
>>>> (evince:5644): EggSMClient-WARNING **: Failed to connect to the session
>>>> manager: None of the authentication protocols specified are supported
>>>> (evince:5644): Gtk-WARNING **: Attempting to read the recently used
>>>> resources file at `/home/jd/.local/share/recently-used.xbel', but the
>>>> parser
>>>> failed: Failed to open file '/home/jd/.local/share/recently-used.xbel':
>>>> Permission denied.
>>>> (evince:5644): Gtk-WARNING **: Attempting to store changes into
>>>> `/home/jd/.local/share/recently-used.xbel', but failed: Failed to create
>>>> file '/home/jd/.local/share/recently-used.xbel.32GDPW': Permission denied
>>> Did you check the permissions on that folder to make sure you have
>>> create permission?
>>> Colin
>> Yes! perms set to rwx for owner only.
> That is only half the answer.  Who is the owner?
> Are you able to manually create the files that it is having problems
> creating?  I am surprised you have not tried that already.
> What happens if you do
> touch /home/jd/.local/share/recently-used.xbel
> Colin
Hi Colin,
Thanx for responding, but ...
You think I would be wasting my time and this list's
subscribers time and post a problem about someone else's
Do you think that when I run evince, it tries
to write in someone else's directory?

And by the way, no user manually creates
the directory /home/<user's name>/.local/share/ .
It is done by the apps themselves.
So, whatever perms are there, are set by the apps.



More information about the ubuntu-users mailing list