The system bell doesn't work in a gnome-terminal

Csányi Pál csanyipal at
Sat Aug 25 08:58:24 UTC 2012

Colin Law <clanlaw at> writes:

> On 25 August 2012 08:40, Csányi Pál <csanyipal at> wrote:

>> I just installed Ubuntu Desktop 12.04.1 LTS 64 bit and realise that that
>> there the system bell doesn't work in a gnome-terminal. Why? How can I
>> fix this?
> What are you doing that should sound the bell but is not?

I did the followings.

1. Edited /etc/modprobe.d/blacklist.conf:
# ugly and loud noise, getting on everyone's nerves; this should be done by a
# nice pulseaudio bing (Ubuntu: #77010)
#blacklist pcspkr

2. Edited /etc/pulse/
### Load X11 bell module
load-module module-x11-bell sample=bell-windowing-system

3. Enable in gnome-terminal the Terminal Bell by checking it.

4. Relogin into Unity environment.

5. Tried also to run the command in gnome-terminal:
   'xset b on'.

6. When I run 'beep' I can heare the sound, but that isn't the sound of
   the PC's internal speaker.

7. When I run 'echo foo | wall' I can heare the PC's internal speaker.

8. Also I'm trying to setup the sound with:

I find something here:

The fields follows:
bell-custom-file: is empty
bell-duration: 100
bell-mode: on
bell-pitch: 400
click: checked in
click-volume: 0
delay: 500

9. Also I'm trying to setup the sound with:
   ccsm, that is, the CompizConfig

Here in General Settings I have checked in the Bell.

Regards from Pal

More information about the ubuntu-users mailing list