Locked out of machine - please help [SOLVED]

R Kimber richardkimber at btinternet.com
Fri Sep 30 21:08:55 UTC 2011

On Thu, 29 Sep 2011 17:21:18 +0100
richardkimber at btinternet.com wrote:

> While adding a user to a group (in a new installation), via the KDE
> settings panel, the process seemed to go OK in the gui, but I found that
> the new group was not listed on the command line by the 'groups'
> command. When I tried to logout I got a message saying that policykit
> had crashed, and I then found that I could not log back in. I tried
> maintenance mode but couldn't get access.
> I booted up a rescue session and set up passwords for both user and
> root, but neither was accepted by the system.  I just can't get access
> to the machine at all.
> Is there anything I can do, short of re-installing?  It's taken me
> two and a half days to do the install and set everything up :-( so I'd
> like to be able avoid doing that again. Is there perhaps a package that
> could be re-installed in the rescue session that might solve it?

It turned out that in re-setting the passwords from the root shell available
via the 'repair broken system' option on the dvd, you mustn't use the same
password as the one that failed.  I had assumed that you could reset
a password to anything you wanted, including the previous one. Clearly you
are limited to a subset of all possible passwords that doesn't include the
one that failed. Presumably re-setting the password doesn't update other
information that is crucial to letting you into the system, unless a
different one is detected.

Once I set a *completely* new password I was able to login normally.  Thanks
to NoOp for his offline support and advice on this.

- Richard.
Richard Kimber
Political Science Resources

More information about the ubuntu-users mailing list