Nasty mess installing sendmail

Harry Putnam harry.put3 at
Wed Sep 28 04:16:14 UTC 2011

Do to unbridled personal bungling, I've created a nasty mess while
installing sendmail.

I inadvertantly deleted /etc/init.d/sendmail.  Well I thought I'd just
reinstall sendmail to re-aquire that file.

So uninstalled sendmail... with aptitude but it uninstalled a few
other parts of the tools tool.

There appear to be several packages involved.
p   sendmail
i   sendmail-base
C   sendmail-bin
i   sendmail-cf       

As you see I now have some installed and some not.  The rub comes with
sendmail-bin which is the package that contains /etc/init.d/sendmail

Any attempt to uninstall it tells me it is not installed, any attempt
to install it ends with an error that appears to happend due to that
missing file, or the fact that sendmail-bin cannot be --configured.

I've tried any number of ways to sneak up on it, but aptitude won't
let me.  Or more acurately I don't know how to use aptitude well
enough to resolve the problem.

I tried apt-get with the --force-yes flag, in the hopes of forcing the
install but it didn't work... showed the same dpkg error.

| /etc/mail/aliases: 4 aliases, longest 10 bytes, 66 bytes total
| invoke-rc.d: unknown initscript, /etc/init.d/sendmail not found.
| dpkg: error processing sendmail-bin (--configure):
|  subprocess installed post-installation script returned error exit
|  status 100
| Errors were encountered while processing:
|  sendmail-bin
| E: Sub-process /usr/bin/dpkg returned an error code (1)

So, can anyone recommend some method to get past this, and get the
pkgs fully installed?

More information about the ubuntu-users mailing list