two perl packages each installed, and that screwed me

Robert P. J. Day rpjday at
Wed Sep 21 19:06:49 UTC 2011

  if you can stand one more post on this topic, i have one more ubuntu
perl packaging issue to resolve.  here's what solved build problems
for every package but one from my earlier post:

On Wed, 21 Sep 2011, Robert P. J. Day wrote:

>   long story short, a bunch of package builds kept failing because
> of a missing symbol (Perl_Gthr_key_ptr), and i finally tracked it
> down to:
> $ dpkg -S /usr/lib/perl/5.10.1/auto/Cwd/
> perl-base: /usr/lib/perl/5.10.1/auto/Cwd/
> $ dpkg -S /usr/lib/perl5/auto/Cwd/
> libfile-spec-perl: /usr/lib/perl5/auto/Cwd/
> $
>   yes, two different packages, both of which contributed and
> the build was picking up the second one which was *wrong*, so i
> deleted that package (which had no dependencies) and, suddenly, my
> build is off and running.
>   why do two different packages contribute the same file?  isn't that
> some kind of packaging bug?

  however, there's one more package that still has build errors for a
*similar* but not identical reason, for which the error message is:

perl: symbol lookup error: /usr/lib/perl5/auto/HTML/Parser/
undefined symbol: Perl_Istack_sp_ptr

  so, it's the same *type* of error but for another .so file and
symbol.  *however*, in this case, i see no duplication of
files.  there is only one file anywhere under all of /usr,
and it's part of the package libhtml-parser-perl, which if i tried to
remove, bad things would happen:

The following packages will be REMOVED:

apparmor-utils* cdbs* gnome-system-tools* gnucash* icoutils* intltool*
libfinance-quote-perl* libhtml-format-perl* libhtml-parser-perl*
libhtml-tableextract-perl* libhtml-tree-perl* libnet-dbus-perl*
liboobs-1-4* liboobs-1-5* libparse-debcontrol-perl* librpc-xml-perl*
libtex-encode-perl* libwww-perl* libxml-parser-perl*
libxml-sax-expat-perl* libxml-treebuilder-perl* libxml-twig-perl*
libxml-xpath-perl* publican* python-distutils-extra*
quickly-ubuntu-template* system-tools-backends* ubuntu-desktop*

  so i'm not sure what to do here.  this is the last annoying issue so
it would be nice to put it to bed.  advice gratefully received.



Robert P. J. Day                                 Ottawa, Ontario, CANADA


More information about the ubuntu-users mailing list