"error: out of disk" grub rescue on first cold boot

Colin Watson cjwatson at ubuntu.com
Tue Sep 13 11:48:34 UTC 2011

On Mon, Sep 12, 2011 at 01:44:08AM +0100, Liam Proven wrote:
> On 6 August 2011 13:57, Burton, Michael <Michael.Burton at xenuclear.com> wrote:
> > Have you solved this yet? I am having the same problem.
> For what it's worth, I had it too with a test install of Oneiric on a
> box which had been running Natty just fine.
> I retried with Lubuntu 11.10 beta 1 (as my dual-Athlon with 512MB RAM
> was labouring to run Unity 2D, pretty as it was), and found that if I
> created a 128MB ext2 /boot partition at the start of the disk, then
> put / and swap into logical partitions, it worked fine.

That would indicate that your BIOS is buggy and unable to read past a
certain point on the disk.  If a BIOS upgrade is available it may help;
otherwise your solution is the best available, until we get to the point
where we can just have GRUB do its own ATA commands by default.

Colin Watson                                       [cjwatson at ubuntu.com]

More information about the ubuntu-users mailing list