Video recording problem [solved]

Patton Echols p.echols at
Wed Jul 27 15:45:53 UTC 2011

On 07/22/2011 09:22 AM, J wrote:
> On Fri, Jul 22, 2011 at 11:33,<p.echols at>  wrote:
>> Greetings all:
>> I am attempting to record video from a webcam on my laptop.  The laptop is an Asus "netbook" Eee PC 1005PEB with 2GB memory, running ubuntu 10.4  The webcam I am attempting to use is a logitech QuicCam Pro.
>> What happens is that, when I start Cheese, the application displays smooth video on screen.  When recording, the video becomes very jerky and will hang badly.  It is as if watching a slide show with freeze frames for several seconds, short snips of motion, followed by more freeze frames.
>> When searching for help with this problem, the sites I have found are discussing playback issues. By playing the webcam video on my desktop I am able to confirm that this is a recording issue on the laptop, not playback.
>> If it matters, I do have playback issues, both on this laptop and my desktop when playing HD video, but the desktop at least is able to play video properly using xine.
>> Does anyone have experience with recording video on this or a similar netbook?  Any thoughts on how I might troubleshoot? I have a project coming up that needs to use an external cam, not the builtin.  (Ok, I don't have it working either, but I have not done the homework to feel like a query to the list is justified.)
> My guess is that is just the result of trying to record/encode/write
> video on a system running a pretty lightweight processor. Even with
> 2GB of RAM, I have a feeling you're just overloading the processor and
> your video issues are due to that.  I had the same issues (and still
> do) on my Lenovo S10 running a slightly older Atom processor than
> yours.  I bet if you tried the same camera on a laptop with a core i3,
> i5 or i7 you'd see much different results.
> You also didn't mention if you were recording in HD or not.  If you
> are, try dropping the resolution down to something lower and see if
> that improves the situation.
> Cheers
> Jeff
Thanks Jeff,

I don't think it is a processor problem.  There seem to be two solutions 
that work.  One (suggested by "user1", thanks) is to use guvcview.

The other is ffmpeg.  FYI to those who might find this thread, the 
ffmpeg string I used was:
ffmpeg -f oss -i /dev/dsp -f video4linux2 -r 24 -s 800x600 -i 
/dev/video0 -sameq test-1.mpg

Adjust to suit.  It is even possible to record from two cameras at once, 
though on this netbook, that does run into processor issues.  It seems 
that only one can capture from /dev/dsp at a time, so the other has to 
be silent movie.  Substitute -an for the audio portion of the string.

Still can't get this unit to use the internal mic, but that's for 
another day.

More information about the ubuntu-users mailing list