ffmpeg makes me mad…

Johnny Rosenberg gurus.knugum at gmail.com
Sat Jul 16 08:55:42 UTC 2011

I have a mpeg file that I made with my video camera at 16:9, but Totem
plays it as 4:3 which makes it look wrong, of course, when View →
Aspect ratio is set to Auto.

So I tried to correct it using ffmpeg:

ffmpeg -i Bkib.mpeg -vcodec copy -aspect 16:9 -acodec copy Bkib-0.mpeg
It seems like ”-vcodec copy” overrides ”-aspext 16:9”, so next one to
try was this one:

ffmpeg -i Bkib.mpeg -aspect 16:9 -acodec copy Bkib-0.mpeg
Now I get my 16:9 copy of the video, but the bitrate is way too low
(about 400 kbps – the original is at 4000 kbps), so I tried this one:

ffmpeg -i Bkib.mpeg -b 4000 -aspect 16:9 -acodec copy Bkib-0.mpeg
Didn't help though. It still lands around 400 kbps.
I also tried to move around the parameters a bit:

ffmpeg -i Bkib.mpeg -aspect 16:9 -b 4000 -acodec copy Bkib-0.mpeg
Didn't affect the result though.

What am I doing wrong?

Kind regards

Johnny Rosenberg

More information about the ubuntu-users mailing list