Re: ”Package dependencies can not be solved”

Liam Proven lproven at
Sat Dec 3 17:43:50 UTC 2011

On 3 December 2011 17:22, Johnny Rosenberg <gurus.knugum at> wrote:
> 2011/12/3 Liam Proven <lproven at>:
>> On 3 December 2011 16:47, Johnny Rosenberg <gurus.knugum at> wrote:
>>> ”This error could be caused by required additional software packages
>>> which are missing or not installable. Furthermore there could be a
>>> conflict between software packages which are not allowed to be
>>> installed at the same time.”
>>> Details:
>>> ”The following packages have unmet dependencies:
>>> language-pack-gnome-sv; language-pack-sv;”
>>> First time I got this was when doing one of those updates using the
>>> update manager. I thought that maybe some of the stuff I installed
>>> myself could be the reason, so I installed Ubuntu 11.10 again, but
>>> from scratch this time (except that I kept my old /home partition).
>>> When starting up I was informed that the Swedish language support was
>>> not complete and I was asked to fix it. I said yes and after a while
>>> this error message popped up again.
>>> Is this fixable or should I just wait for the next update and hope
>>> they fixed it…?
>> Have you tried to do this?
>> sudo apt-get install -f
> I tried it in my old install and it didn't help. I didn't try it since
> the fresh install though, but I will now. Wait… :)
> Reading package lists... Done
> Reading state information... Done
> 0 to upgrade, 0 to install, 0 to remove and 252 to not upgrade.
> (The last line was in Swedish, so the above is my translation of it).

Inga problem. Jag kan förstå en lite svenska. :¬)

> Nothing more happened, so I'll try to install complete language
> support again now:
> Clicking Language Support
> A dialogue box pops up, saying something like this, I translate from Swedish:
> ”Your language support is not fully installed
> Some translations are available for your selected languages and they
> are still not installed. Do you want to install them now?
> language-pack-sv
> language-pack-gnome-sv
> language-pack-sv
> [Remind me later] [Install]”
> I clicked Install.
> By the way, why are language-pack-sv mentioned twice…?
> ”Package dependencies cannot be resolved” and so on, in other words: FAIL.
> Thanks for the input, though.

I think this is a known problem - I had the same error on my clean
install of 64-bit Oneiric. Don't know what the solution is, though,
but it might be worth hunting through Launchpad...

Liam Proven • Info & profile:
Email: lproven at • GMail/GoogleTalk/Orkut: lproven at
Tel: +44 20-8685-0498 • Cell: +44 7939-087884 • Fax: + 44 870-9151419
AIM/Yahoo/Skype: liamproven • MSN: lproven at • ICQ: 73187508

More information about the ubuntu-users mailing list