Trying to Load Ubuntu 11.04 onto HP Laptop. Failed at reboot

Peter Fitzpatrick Peter at
Sun Aug 28 03:35:34 UTC 2011

Hi Tom

Tried as you suggested but am not familiar with the system to get the script
to run. So I did not get as far as the grub probes.
Can you detail the process a little more for the newbie


Have also checked the BIOS settings and there is nothing available that I
can find that should change the actions of the HDD. The laptop does a finger
print sensor (not used) but runs on USB as well as a Memory card reader,
also on USB. Can not find any way to turn these off in Bios.

-----Original Message-----
From: ubuntu-users-bounces at
[mailto:ubuntu-users-bounces at] On Behalf Of Tom H
Sent: Wednesday, 24 August 2011 11:16 PM
To: ubuntu-users at
Subject: Re: Trying to Load Ubuntu 11.04 onto HP Laptop. Failed at reboot

On Wed, Aug 24, 2011 at 6:37 AM, Peter Fitzpatrick
<Peter at> wrote:
> There is a swap partition I believe it is Hd0,5. I ran Ubuntu from the CD
> (and USB) install disk and looked at the drive with gpart.
> The current version loaded is the 10.04 version and this one comes up
> Error: Out of disk
> Grub rescue> ls
> (hd0) (hd0,1)
> Grub rescue> set
> Prefix=(hd0,1)/boot/grub
> Root=hd0,1
> Grub rescue> insmod (hd0,1)/boot/grub/normal.mod
> Error: out of disk
> Grub rescue>
> Does 'out of disk' mean out of disk space?

AFAIK, "out of disk" is simply related to not finding a module (or modules).

The fact that the "ls" doesn't list the swap partition makes me think
that grub isn't installed properly and that no amount of messing
around at the "grub" prompt will result in a proper boot.

If I were you, I'd boot from the installation CD, download bootinfo from
run it, run a few grub-probes[1], re-install grub, re-run bootinfo and
the grub-probes, and post everything as well as "blkid -c /dev/null"
(the "/dev/null" is to skip the cache not to delete anything!) for us
to see if there's a difference - and of course, whether you can boot.

1. grub-probes:

mount "/" (you seem to have the plain install with "/" on sda1 and
swap on sda5) on /mnt, then

for target in fs fs_uuid device drive partmap abstraction
echo "## $target probe of /mnt ##"
/usr/sbin/grub-probe --target $target /mnt
echo "## $target probe of /dev/sda ##"
/usr/sbin/grub-probe --target $target --device /dev/sda
echo "## $target probe of /dev/sda1 ##"
/usr/sbin/grub-probe --target $target --device /dev/sda1

ubuntu-users mailing list
ubuntu-users at
Modify settings or unsubscribe at:

More information about the ubuntu-users mailing list