Trying to Load Ubuntu 11.04 onto HP Laptop. Failed at reboot

Peter Fitzpatrick Peter at
Sun Aug 28 03:31:25 UTC 2011

Hi. Unfortunately I have no better news to report.

Have tried the suggestions from Goh Lip with the same response for each try
with the exception of the following after deleting partitions and manually
setting I had Primary partition 1 as an ext4 disk with 300GB (sda1) and
primary partition 2 as the Swap with 5GB (sda2).
Reinstalling and rebooting gave:

Error: out of disk
Grub rescue> ls
(hd0) (hd0,msdos2) (hd0,msdos1)
Grub rescue> set
Grub rescue>

I also tried to run the boot info script but ran into troubles. See other
response to Tom H.

-----Original Message-----
From: ubuntu-users-bounces at
[mailto:ubuntu-users-bounces at] On Behalf Of Goh Lip
Sent: Wednesday, 24 August 2011 10:48 PM
To: ubuntu-users at
Subject: Re: Trying to Load Ubuntu 11.04 onto HP Laptop. Failed at reboot

On 24/08/11 17:53, Peter Fitzpatrick wrote:
> Thanks for the assistance so far. Anything else I can try?

Okay, boot up 11.04 livecd and at terminal, do the following...
sudo mount /dev/sda1 /mnt
sudo grub-install --boot-directory=/mnt/boot /dev/sda

reboot without livecd.

Peter, Tom and Ric is right to worry about your disk. If the above does 
not work, suggest you re-install. But before re-installing, ensure your 
disk is okay first. Since there is no other OS on your disk, use a 
gparted cd and .....

o delete all partitions
o at the device tab, set device to "msdos"
o create your partitions
   sda1   ext4
   sda2   swap

swap can be about 2 times your ram memory and the balance for sda1. You 
can of course create more partitions for any further expansions.

Then only re-install.

Good luck - Goh Lip

ubuntu-users mailing list
ubuntu-users at
Modify settings or unsubscribe at:

More information about the ubuntu-users mailing list