LibreOffice3 on Natty fails with "com::sun::star::uno::RuntimeException"

NoOp glgxg at
Wed Aug 17 03:04:19 UTC 2011

On 08/16/2011 02:57 PM, Charlie Zender wrote:
> Hello,
> LibreOffice3 fails to start and issues the error:
> terminate called after throwing an instance of
> 'com::sun::star::uno::RuntimeException'
> This happens with both a clean install of Natty and with a version
> upgraded from Maverick. Prior to upgrading from Maverick->Natty,
> OpenOffice3 worked fine.
> Googling this problem yields a bunch of hits, but no solutions (for
> me). I have tried removing and re-installing all traces of
> LibreOffice.

If it weren't for the clean install of Natty it would sound like a
profile issue. On the Maverick-Natty upgrade machine can you try the

1. Rename your ~/.libreoffice folder to ~/.libreoffice_bak
2. Restart LO

See if it still throws the error. Note: you can always delete the new
~/.libreoffice folder that LO will create on starting up & rename your

On the clean Natty install, did you copy any of the ~/.openoffice
profiles over?

On either machine you can also test the standard LO version in parallel
with your Natty LO. Download both the main package and the help package

Extract both files (right-click in Nautilus & select 'Extract here'. In
a terminal cd to the 'DEBS' folder, example:
$ cd /home/<user>/LibO_3.4.2rc3_Linux_x86_install-deb_en-US/DEBS
and install:

$ sudo dpkg -i *.deb

Then modify the bootloader so that it creates a profile seperate from
your Ubuntu ~/.libreoffice:

$ gksu gedit /opt/libreoffice3.4/program/bootstraprc
or if you downloaded 3.3:
$ gksu gedit /opt/libreoffice/program/bootstraprc
and modify:

to read:

save and then start LO:

$ /opt/libreoffice3.4/program/soffice

More information about the ubuntu-users mailing list