control key stops working in VirtualBox! With answer.

Karl Auer kauer at
Wed Aug 3 11:57:16 UTC 2011

Here's a strange one for ya:

I had a VM running Ubuntu Server 8.10 under VirtualBox 4.0.12. Inside
that VM, CTL-C didn't work; it was as if I never pressed CTL at all. Nor
did any other tried, true and trusted CTL-combinations, like CTL-D,
CTL-Z etc. Nothing more frustrating than starting an ordinary ping and
having to kill the VM to regain control (yes, Virginia, there ARE VMs
that are not accessible via ssh).

Futzed around for half an hour before the light dawned: I had enabled
"show position of pointer when the Control key is
pressed" (System->Preferences->Mouse) for a presentation, and had not
turned it back off.

Now I didn't actually *know* that was the problem, but it seemed so
luminously clear when I thought of it that I would have been stunned had
it NOT been the problem, and indeed so it was. Turned off that setting,
and lo! CTL started working in my VMs again.

So I turned the setting back on to see what else broke (what a hero).
"Right-CTL to uncapture mouse pointer" didn't work, for a start; the
only way out of that one was to do a formal shutdown of the VM, 'cos I
couldn't get the focus back to outside the VM window. It did *sort of*
work, because when I then moved the mouse about and pressed either CTL,
the neato location display reported the mouse pointer location being
elsewhere on the screen, and that location was consistent with the mouse
movements I'd made, but it was not effective at those locations (i.e.,
clicking did nothing). The fact that the mouse cursor had vanished when
the VM captured the pointer and was not restored by pressing right-CTL
also severely reduced its usefulness.

I hadn't noticed it before, but with my new heightened awareness I now
realised that pressing either CTL key "dimmed" the highlight on selected
objects. That is, if I had (for example) selected a file in the file
manager, the colour surrounding that file's icon went a shade or two
darker from the moment a CTL key was pressed until the location display
had finished, then went back to normal.

CTL-ALT-Fx still worked to take me to a text console. CTL-leftclick also
still worked to select multiple objects in the file manager.

At that point I got bored :-)

So beware, VM users, of that setting!

Regards, K.

PS: Bug #613833 - slightly different symptoms, clearly the same thing
though. Looks like someone is not passing the key event along properly.
Whether stuff works seems to be related to how close they are to the
original key-press (or possibly key-release) event - before or after the
location display hook, I guess. VirtualBox says "not our problem - we
can't do anything about events we don't see!" Fair enough, but they do
appear to partially uncapture the mouse pointer... hm.

Karl Auer (kauer at                   +61-2-64957160 (h)                   +61-428-957160 (mob)

GPG fingerprint: DA41 51B1 1481 16E1 F7E2 B2E9 3007 14ED 5736 F687
Old fingerprint: B386 7819 B227 2961 8301 C5A9 2EBC 754B CD97 0156
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part
URL: <>

More information about the ubuntu-users mailing list