Multibooting with Grub2

Tom H tomh0665 at gmail.com
Fri Oct 29 03:55:04 UTC 2010


On Thu, Oct 28, 2010 at 10:41 PM, Liam Proven <lproven at gmail.com> wrote:
> On Wed, Oct 27, 2010 at 6:20 AM, Tom H <tomh0665 at gmail.com> wrote:
>> On Tue, Oct 26, 2010 at 9:37 PM, Liam Proven <lproven at gmail.com> wrote:
>>>
>>> I am setting up a multiboot PC for testing. It has FreeBSD 8.1, Ubuntu
>>> 9.04, 10.10 and Debian 5, so far. I plan to add more.
>>>
>>> The snag is the 'buntus and Debian all want to run Grub2, & Grub2 only
>>> wants to go in the MBR. I don't want it in the MBR - it means that if
>>> I am in 1 distro & get a kernel update, the Grub from the other distro
>>> doesn't see it. Only 1 copy of Grub2 can be active at a time.
>>>
>>> I want a bootloader in each OS's root partition and a separate 3rd
>>> party one in the MBR. Currently I'm using XOSL in a tiny 32MB FreeDOS
>>> partition, but it can't boot the Linuxes 'cos their Grub2s have gone.
>>>
>>> Grub2 issues terrifying warnings if I try to install it to the
>>> partition instead of the disk. Is this in fact safe?
>>>
>>> Grub1 seems to be deprecated and missing in 10.10 and Debian "Lenny" -
>>> the choices are Grub2 or LILO.
>>
>> grub1 is still available, as "grub".
>
> I think that, unfortunately, the 1st distro I tried is based directly
> off Debian, not off Ubuntu any more, and sadly, this appears to mean
> that Grub1 was no longer an option. There was no package for it in
> Synaptic, so I went with Lilo.

In Debian, grub1 is grub-legacy and is still available; although it
might be deep-sixed once Squeeze goes RC or is released.


>> Don't forget to have a separate
>> ext2/3xt3 "/boot" or to have an ext2/ext3 "/" if you use
>> grub/grub1/grub-legacy rather than grub2 because grub1 can't handle an
>> ext4 "/boot".
>
> Aha! I didn't know that. Thanks, very useful tip.

You're welcome.


> Since I do not own a hard disk bigger than 150GB, I never choose ext4,
> always ext3, but I may have left some installations on defaults and
> that can mean ext4 now.
>
>> You don't have to install grub2 to the MBR. The installed even offers
>> to install to a partition now; it might use block lists but I'm not
>> sure about that.
>
> Good to know. Thanks again.

You're welcome.


>> You can only have one grub2 "active" in the MBR but you can chainload
>> with either chainload or configfile to the other grub2 installs.
>
> I have tried this, but never got it working reliably.

It's worked for me with six distributions.


>> [FYI, when I attach the FreeBSD disk to one of the other VMs, the BSD
>> partitions are detected (they are listed with "dmesg | grep bsd"),
>> grub-mkdevicemap adds the disk to "/boot/grub/device.map", "grub-probe
>> --target=drive --device /dev/sdb5" lists the disk as "(hd1,msdos1)"
>> (strangely not "(hd1,msdos1,bsdX)", but neither update-grub nor
>> os-prober (the same thing, I know, but I thought that I'd check
>> anyway) detect it. At the grub cli, ls lists "(hd1,msdos1)" and
>> "(hd1,msdos1,msdos4)".]
>
> I find I cannot mount my BSD partition. I have installed the UFS
> utilities and can even fsck it, but I can't mount it. I've tried
> ``mount'', ``mount -t ufs'', & ``mount -t ufs -o=ufs2'' (or something
> like that) - nothing works.

I cannot mount BSD partitions with Maverick, Natty, or Sid (with a bad
magic number error). I've tried various options with the same result.
There's a one-post thread on debian-user-german where the OP has gone
through the same steps that I did and no one has responded. It used to
work though!


> *But* it suddenly occurs to me - with FreeBSD 8, which PC-BSD 8.1 is
> based upon, there are multiple slices within that 1 primary partition.
> Maybe I need to mount slices directly. I don't know how to do that.

That's ok. Linux recognizes the ufs slices and partitions as linux
partitions. Run "dmesg | grep bsd" and they'll be listed.




More information about the ubuntu-users mailing list