Multibooting with Grub2

Liam Proven lproven at gmail.com
Fri Oct 29 02:43:55 UTC 2010


On Fri, Oct 29, 2010 at 3:41 AM, Liam Proven <lproven at gmail.com> wrote:
> On Wed, Oct 27, 2010 at 6:20 AM, Tom H <tomh0665 at gmail.com> wrote:
>> On Tue, Oct 26, 2010 at 9:37 PM, Liam Proven <lproven at gmail.com> wrote:
>>>
>>> I am setting up a multiboot PC for testing. It has FreeBSD 8.1, Ubuntu
>>> 9.04, 10.10 and Debian 5, so far. I plan to add more.
>>>
>>> The snag is the 'buntus and Debian all want to run Grub2, & Grub2 only
>>> wants to go in the MBR. I don't want it in the MBR - it means that if
>>> I am in 1 distro & get a kernel update, the Grub from the other distro
>>> doesn't see it. Only 1 copy of Grub2 can be active at a time.
>>>
>>> I want a bootloader in each OS's root partition and a separate 3rd
>>> party one in the MBR. Currently I'm using XOSL in a tiny 32MB FreeDOS
>>> partition, but it can't boot the Linuxes 'cos their Grub2s have gone.
>>>
>>> Grub2 issues terrifying warnings if I try to install it to the
>>> partition instead of the disk. Is this in fact safe?
>>>
>>> Grub1 seems to be deprecated and missing in 10.10 and Debian "Lenny" -
>>> the choices are Grub2 or LILO.
>>
>> grub1 is still available, as "grub".
>
> I think that, unfortunately, the 1st distro I tried is based directly
> off Debian, not off Ubuntu any more, and sadly, this appears to mean
> that Grub1 was no longer an option. There was no package for it in
> Synaptic, so I went with Lilo.
>
>> Don't forget to have a separate
>> ext2/3xt3 "/boot" or to have an ext2/ext3 "/" if you use
>> grub/grub1/grub-legacy rather than grub2 because grub1 can't handle an
>> ext4 "/boot".
>
> Aha! I didn't know that. Thanks, very useful tip.
>
> Since I do not own a hard disk bigger than 150GB, I never choose ext4,
> always ext3, but I may have left some installations on defaults and
> that can mean ext4 now.
>
>> You don't have to install grub2 to the MBR. The installed even offers
>> to install to a partition now; it might use block lists but I'm not
>> sure about that.
>
> Good to know. Thanks again.
>
>> You can only have one grub2 "active" in the MBR but you can chainload
>> with either chainload or configfile to the other grub2 installs.
>
> I have tried this, but never got it working reliably.
>
>> There was just a thread in help-grub where someone couldn't load
>> FreeBSD with grub2. I've just tried in three VMs (Maverick, Natty, and
>> Sid) and didn't get anywhere and the OP has posted that he found a
>> thread in grub-devel which said that there were problems with freebsd.
>
> :-(
>
>> [FYI, when I attach the FreeBSD disk to one of the other VMs, the BSD
>> partitions are detected (they are listed with "dmesg | grep bsd"),
>> grub-mkdevicemap adds the disk to "/boot/grub/device.map", "grub-probe
>> --target=drive --device /dev/sdb5" lists the disk as "(hd1,msdos1)"
>> (strangely not "(hd1,msdos1,bsdX)", but neither update-grub nor
>> os-prober (the same thing, I know, but I thought that I'd check
>> anyway) detect it. At the grub cli, ls lists "(hd1,msdos1)" and
>> "(hd1,msdos1,msdos4)".]
>
> I find I cannot mount my BSD partition. I have installed the UFS
> utilities and can even fsck it, but I can't mount it. I've tried
> ``mount'', ``mount -t ufs'', & ``mount -t ufs -o=ufs2'' (or something
> like that) - nothing works.
>
> *But* it suddenly occurs to me - with FreeBSD 8, which PC-BSD 8.1 is
> based upon, there are multiple slices within that 1 primary partition.
> Maybe I need to mount slices directly. I don't know how to do that.
>
> Why can't BSD just play the game, like other PC OSs, and just
> understand & use the PC partitioning system directly? >_<

Sorry, I forgot - what I /was/ going to say was: if Linux can't mount
the partition, does that not mean that Grub can't look inside it and
see what kernels or whatever are in there for Grub to add to its boot
menu?

-- 
Liam Proven • Info & profile: http://www.google.com/profiles/lproven
Email: lproven at cix.co.uk • GMail/GoogleTalk/Orkut: lproven at gmail.com
Tel: +44 20-8685-0498 • Cell: +44 7939-087884 • Fax: + 44 870-9151419
AIM/Yahoo/Skype: liamproven • MSN: lproven at hotmail.com • ICQ: 73187508




More information about the ubuntu-users mailing list