use of fschk

Joep L. Blom jlblom at
Mon Oct 18 08:44:57 UTC 2010

Joep L. Blom wrote:
> Basil Chupin wrote:
>> On 14/10/2010 21:48, Joep L. Blom wrote:
>>> I, have- I hope - a rather simple question.
>>> My HD (1 year old: ATA SAMSUNG HD502HI).
>>> Since several weeks I get kernel errors related to this disk like:

>> Go to init 1 (CTRL-ALT-F3 then do init1) then
>> mount -o remount,ro /dev/sd<X>
>> where the <x> is where the system is installed and perform the fsck (eg, 
>> e2fsck /dev/sdX).
>> After the check is finished,
>> mount -o remount, rw /dev/sd<X>
>> then reboot.
>> [NOTE: "-o" is not "-zero" but the letter "o".]
>> BC
Colin & Basil,
As a follow up, I tried both your suggestions.
(Colin: sudo touch /forcecheck) but neither worked as Basil's solution 
refused to do the mounts as the partition was not unmounted and I 
couldn't unmount it and Colin's solution didn't work but that's perhaps 
because I used /dev/sda instead of /dev/sda1.
So I still haven't checked my file-system. However, my son suggested to 
replace the serial disk cable as cables are known to give problems. 
Since I did that (yesterday) I have the impression the disk is much less 
accessed but I have to wait for the kernel log to see if the problem is 

More information about the ubuntu-users mailing list