How do I install g++ 4.5 on ubuntu 10.10?

K. Frank kfrank29.c at gmail.com
Fri Nov 19 00:12:42 GMT 2010


Hi Ric -

On Thu, Nov 18, 2010 at 7:05 PM, Ric Moore <wayward4now at gmail.com> wrote:
> On Thu, 2010-11-18 at 18:46 -0500, K. Frank wrote:
>> (It may have complained
>> about missing dependencies -- I don't remember precisely.)
>
> That, I think, is the core of your problem. I just checked the depends
> on my installed version of g++ and it lists several ~major~ packages
> that I don't think I'd dink with, like gcc. Any newer version of g++
> would have to have those satisfied, so please report the error messages
> you received. I'm thinking this is not minor stuff. Ric

Well, here's one example:

I right click on:

   gcc-4.5_4.5.1-10ubuntu1_i386.deb

and select "Open With Ubuntu Software Center."

Ubuntu Software Center displays the message:

   Dependency is not satisfiable: gcc-4.5-base (= 4.5.1-10ubuntu1)

(Remember that my system is not in the same state as
it was the first time I tried this -- I have since run dpkg
and Synaptic, as described in my previous posting.)

Thanks for your help.


K. Frank



More information about the ubuntu-users mailing list