Problem with perl DBI => postgress after upgrade

Mark mhullrich at
Fri Nov 12 21:03:17 UTC 2010

On Fri, Nov 12, 2010 at 12:13 PM, Aart Koelewijn <aart at> wrote:
> On Fri, 12 Nov 2010 19:48:14 +0000, Aart Koelewijn wrote:
>> I run a home-written perl program to fill a postgres database with
>> measurements. In this program I have the line:
>> $dbh = DBI->connect("dbi:Pg:dbname=$dbname;host=$host","","");
>> This always worked fine. Since I upgraded my box from Ubuntu 10.04 to
>> 10.10 this afternoon, when I try to run the program I get:
>> DBI connect('dbname=bluetooth;host=mtack3','',...) failed: fe_sendauth:
>> no password supplied at bin/ line 62 Can't call method
>> "prepare" on an undefined value at bin/ line 63.
> As often, after posting the problem I find a solution in minutes. After
> changing `my $host="mtack"' in the perl program to `my $host="localhost"'
> all is fine.
One of the nice things about email is that, after one has constructed
a painstaking message describing a problem one needs solved, one can
then wait to send it until after checking that minor little detail
that one has not considered until right before striking the left mouse

That said, I can't count the number of times I've done exactly the
same thing.  At least you went the extra kilometer to post your
solution - thanks.

See?  We're not all perfect....

(Basil, Ric, chime in any time here....  :-)


More information about the ubuntu-users mailing list