[ubuntu-users] NFS

Tom H tomh0665 at gmail.com
Wed Nov 10 18:23:05 UTC 2010

On Tue, Nov 9, 2010 at 11:03 PM, Ted Hilts <ehilts at mcsnet.ca> wrote:
> Tom H wrote:
>> On Mon, Nov 8, 2010 at 11:24 PM, Ted Hilts <thilts at mcsnet.ca> wrote:
>>> I can't seem to get a NFS up and running.
>>> There is a file "/etc/exports" and in that file "/media/dfc1...6cfe3".
>>> The part after the "/media/" is the disk ID.  Also, as sudo I created
>>> "/ted-nfs" as the mount point.  Then  I did the command "sudo mount
>>> /ted-nfs" and the command  "sudo
>>> exportfs ra". I did not use the machine IP addres in the "/etc/exports"
>>> file but did use it in the command. All this occured on just one machine
>>> ( and I have not got past this problem and have also the
>>> "clients" to worry about.
>>> In the man NFS examples I tried all 4 examples but nothing worked. For
>>> example (not using "/etc/exports") I did the example:
>>> "server:/export /mnt nfs defaults 0 0" by putting in the same server,
>>> the export mount, etc to get " /ted-nfs
>>> nfs defaults 0 0" which failed.  The error was just a list of options.
>> Assuming nfs is installed and running.
>> Assuming nfsv4.
>> Server:
>> Client:
>> Directory to export: /media/dfc1...6cfe3
>> Mount point: /ted-nfs
>> Set up
>> $ sudo vi /etc/exports
>> /media/dfc1...6cfe3   *(rw,fsid=0,no_subtree_check,no_root_squash)
>> $ sudo exportfs -rav
>> $ sudo vi /etc/fstab
>>  /ted-nfs  nfs  noexec,nosuid  0 0
>> $ sudo mount -a -t nfs
>> Test
>> $ showmount -e
>> and
>> $ sudo mount
>> and
>> $ ls /ted-nfs
> After executing sudo exportfs -raw I got the response:
> exporting *:/media/...cfe3
> After editing /etc/fstab I did the sudo mount -a -t nfs and got an error
> message:
> "mount.nfs: access denied by server while mounting"
> showmount -e gives the export list for cic2ext.
> sudo mount gives all the mounts including the nfs mounted on proc.
> ls /ted-nfs gives nothing.
> You are welcome to access this machine remotely.

Given the above, I'll assume that nfs is running (for now)...

Do you have any entries in "/etc/hosts.allow" or "/etc/hosts.deny"?

Do you have iptables running without allowing loopback access?

I'd rather not access your box. Let's revisit the idea if the above
doesn't help elucidate what's wrong.

More information about the ubuntu-users mailing list