error in grub2 after delete partition

Luis Paulo luis.barbas at
Mon May 31 06:30:38 UTC 2010

On Mon, May 31, 2010 at 7:21 AM, Luis Paulo <luis.barbas at> wrote:
> On Sun, May 30, 2010 at 10:41 PM, mierdatutis mi <mmm286 at> wrote:
>> I had in one disk:
>> Primary partition: xp
>> Extended partition: ubuntu and windows 7.
>> Now, I've changed the partitions. I delete the primary of xp and the
>> extended of windows 7. I've created a primary partition to install windows
>> 7.
>> After I've installed windows 7, I boot with my ubuntu Live and I did an
>> update-grub.
>> Now I have grub2 installed and I can boot with my ubuntu but when I select
>> windows 7 it says me:
>> no such device: ec3883435345390
>> no such partition.
>> Could you help me please?
>> Many thanks and sorry for my english!
>> --
> You may try this
> Follow the text. You didn't said what version of ubuntu are you using
> (to answer is it grub, grub legacy, grub2?).
> The recheck option will probe your device map, but there's a warning
> on the man page
> I'll try it anyway if the rest fails.
> Then do an sudo update-grub (or sudo update-grub2) on your linux (on
> hdd). Or you may just try this before, as in now. :)
> Worked for me
> Regards
> Luis

Goh Lip is right. If you can run ubuntu, you don't need the live cd
anymore. Good reading, though :)

Try the
$ sudo update-grub (or sudo update-grub2)

If that doesn't work
$ sudo grub-install /dev/sda

If that still doesn't work try with the --recheck option

More information about the ubuntu-users mailing list