updating doesn't work anymore

Joep L. Blom jlblom at neuroweave.nl
Fri May 21 14:02:59 UTC 2010

NoOp wrote:

> Joep, I see your
> https://bugs.launchpad.net/ubuntu/+source/debootstrap/+bug/577834
> You might want to have a look at:
> http://packages.ubuntu.com/karmic/libc-bin
> https://launchpad.net/ubuntu/+source/eglibc/+bugs
> If nothing else, you could download the deb directly & try a reinstall
> from that:
> http://packages.ubuntu.com/karmic/libc-bin
> http://packages.ubuntu.com/karmic/amd64/libc-bin/download
> Use the Gdebi package installer (i.e., double click the deb file in
> Nautilus & it should offer to use Gdebi to install. Or use:
> $ gdebi-gtk libc-bin_2.10.1-0ubuntu15_amd64.deb
> http://packages.ubuntu.com/karmic/gdebi
Gary & Markus,
Thanks for your help so far but the problem remains.
Markus, I used your .triggers file and Gary, I tried gdebi. However, the 
libc-bin from your link is older than the one installed so gedebi complains.
I than tried apt-get with the .triggers file from Markus and this is the 
  sudo apt-get --reinstall install libc-bin
[sudo] password for joep:
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 15 not 
1 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up libc-bin (2.10.1-0ubuntu16) ...
dpkg (subprocess): unable to execute installed post-installation script: 
Exec format error
dpkg: error processing libc-bin (--configure):
  subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
The next thing I can think of is to remove libc-bin completely and then 
reinstall the older version I got from the URL of Gary but I hesitate as 
I don't know if the error is really what is says as I don't know why 
apt-get (or synaptic) need (a program of the package) libc-bin for 
I tried to install a program from synaptic but that failed also. The 
problem worsens now.
I am convinced that it is a simple problem but I hope you guys can give 
me some more clues.

More information about the ubuntu-users mailing list