Installing 10.04 to 2TB disk, does not boot

Matthias Brennwald matthias at
Mon May 17 17:52:08 UTC 2010

On May 17, 2010, at 6:43 PM, ubuntu-users-request at wrote:

> Message: 7
> Date: Mon, 17 May 2010 11:43:50 -0500
> From: Preston Hagar <prestonh at>
> Subject: Re: Installing 10.04 to 2TB disk, does not boot
> To: "Ubuntu user technical support,	not for general discussions"
> 	<ubuntu-users at>
> Message-ID:
> 	<AANLkTikWtoBWb71m-r271W5VioaPSpgYgXtz4WzV7r1P at>
> Content-Type: text/plain; charset=ISO-8859-1
> On Mon, May 17, 2010 at 9:04 AM, Matthias Brennwald
> <matthias at> wrote:
>> Dear all
>> I tried to install Ubuntu 10.04 to a 2TB disk. The installation itself completed without errors (not even when GRUB got installed). However, the system won't boot from the fresh install. After installation and trying to reboot into the new install I only get a message saying that the disk is not bootable. Here's a link to the machine I am using (Tranquil PC Barebones Server):
>> Here's what I tried so far:
>> 1. Installation using the the Live CD. Result: won't boot.
>> 2. Installation using alternate CD. Result: won't boot.
>> 3. I manually formatted the disk to explicitly include a small bios_grub partition, hoping that might help to properly install GRUB2. Then repeated the install from the alternate CD. Result: won't boot.
>> 4. I took another disk with Ubuntu already on it (160 GB, removed from another machine). Result: This boots nicely.
>> 5. Installed to yet another disk (also 160 GB, using the alternate CD). Result: This boots nicely.
>> So, in summary, it looks like the problem is related to my 2TB disk.
>> Please note:
>> - The above tests were done with only one disk installed (the Tranquil PC Barebones Server will take up to 5 disks).
>> - This post is (sort of) a follow up to my earlier post with the subject "Cannot boot from software RAID with 2TB disks". As you can see from this follow up, it looks like the problem I described there was not (only) related to the RAID.
>> Any hints or ideas on how I can make this work with my 2TB disk(s) would be great!
>> Thanks in advance
>> Matthias
>> ----
>> Matthias Brennwald
>> Eawag, CH-8600 D?bendorf
>> Office Eawag BU-C08: +41 44 823 53 05
>> Lab Eawag LA-C76: +41 44 823 53 06
>> Lab ETHZ CLA A31.6: +41 632 09 36/39
>> matthias.brennwald at
> No ideas yet, just a few questions (sorry if they were answered in
> your other thread).
> With the 160 GB drive that worked, was the 2TB drive in the machine at
> the time?


> Did you put the 160 GB drive in the same slot as the 2TB drive?

Not while I worked with the 160 GB drives, of course. But I tried the same slot while installing to the 2 TB drive.

> Can you boot to the 160 GB drive with the 2 TB drive in and see if you
> can mount it and read/write to it?

Yes, I can do that (read/write works).

> When the 2 TB drive fails to boot, where does it fail?
> Does grub or anything show up?
> Are there any error messages?

If fails before GRUB shows up. I just get a message saying that there is no bootable disk.

> This might help out in determining if it is an installation problem,
> disk problem, hardware/bios problem, etc.

In the meantime I found something on the internet which make me believe the problem is related to the motherboard, which needs to be convinced to boot a drive with a GTP partition table on it:

However, I do not really understand what the author means by "The trick was to set the partition in the protective mbr as active", and how to do that. What does he mean by "active"? What is the "partition in the protective mbr"? How can I change these things?


Matthias Brennwald, Käferholzstrasse 173, CH-8046 Zürich, +41 44 364 17 03

More information about the ubuntu-users mailing list